СДАМ ГИА: РЕШУ ОГЭ
Образовательный портал для подготовки к экзаменам
Информатика
информатика
сайты - меню - вход - новости




Варианты заданий
Версия для печати и копирования в MS Word
1
Задание 0 № 4762

Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трех языках программирования.

Алгоритмический язык

алг

нач

цел  a, k

a := 40

нц для k от 2 до 5

a := a k

кц

вывод a

кон

Бейсик

DIM a, k AS INTEGER

a = 40

FOR k = 2 TO 5

  a = a k

NEXT k

PRINT a

END

Паскаль

var a, k : integer;

begin

a := 40;

for k := 2 to 5 do

a := a k;

write(a);

end.


 

 


2
Задание 0 № 4878

Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трех языках программирования.

Алгоритмический язык

алг

нач

цел n, s

s := 2

нц для n от 2 до 5

s := s + n * 2

кц

вывод s

кон

Бейсик

DIM n, s AS INTEGER

s = 2

FOR n = 2 TO 5

  s = s + n * 2

NEXT n

PRINT s

END

Паскаль

var s, n: integer;

begin

s := 2;

for n := 2 to 5 do

s := s + n * 2;

write(s);

end.


 


3
Задание 0 № 5152

Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трех языках программирования.

 

Алгоритмический язык

алг

нач

  цел s, i

  s := 3

  нц для i от 2 до 5

       s := s + 2 * i

  кц

  вывод s

кон

Бейсик

DIM i,s AS INTEGER

s = 3

FOR i = 2 TO 5

  s = s + 2 * i

NEXT i

PRINT s

END

Паскаль

var s,i:integer;

begin

  s := 3;

  for i := 2 to 5 do

     s := s + 2 * i;

  writeln(s);

end.


 


4
Задание 0 № 5185

Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трех языках программирования.

Алгоритмический язык

алг

нач

цел  n, s

s := 1

нц для n от 5 до 8

s := s * 3

кц

вывод s

кон

Бейсик

DIM n, s AS INTEGER

s = 1

FOR n = 5 TO 8

  s = s * 3

NEXT n

PRINT s

END

Паскаль

var s, n: integer;

begin

s := 1;

for n := 5 to 8 do

s := s * 3;

write(s);

end.


 


5
Задание 0 № 5213

Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трех языках программирования.

 

Алгоритмичекий

язык

алг

нач

  цел s,k

  s := 0

  нц для k от 4 до 11

    s := s + k

  кц

  вывод s

кон

Бейсик

dim s,k As INTEGER

s  =  0

FOR k = 4 TO 11

  s = s + k

NEXT k

PRINT s

END

Паскаль

var s, k:integer;

begin

  s := 0;

  for k := 4 to 11 do

    s := s + k;

  writeln (s);

end.              


 


6
Задание 0 № 5235

Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трех языках программирования.

 

Алгоритмический язык

алг

нач

   цел y,i

   y := 0

   нц для i от 1 до 3

         y := y + 4 * i

   кц

   вывод y

кон

Бейсик

DIM i,y AS INTEGER

y = 0

FOR i = 1 TO 3

  y = y + 4 * i

NEXT i

PRINT y

END

Паскаль

var y,i: integer;

begin

  y := 0;

  for i := 1 to 3 do

    y := y + 4 * i;

  writeln(y);

end.


 


7
Задание 0 № 5248

Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трех языках программирования.

Алгоритмический

язык

алг

нач

  цел s,k

  s := 1

  нц для k от 1 до 7

    s := s + k

  кц

  вывод s

кон

Бейсик

DIM s,k AS INTEGER

s  =  1

FOR k =1 TO 7

  s = s + k

NEXT k

PRINT s

END

Паскаль

var s, k:integer;

begin

  s := 1;

  for k := 1 to 7 do

    s := s + k;

  writeln (s);

end.


 


8
Задание 0 № 5292

Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трех языках программирования.

Алгоритмический язык

алг

нач

  цел s, k

  s := 1

  нц для k от 3 до 6

    s := s * k

  кц

  вывод s

кон

Бейсик

DIM s, k AS INTEGER

s = 1

FOR k = 3 TO 6

  s = s * k

NEXT k

PRINT s

END

Паскаль

var s,k: integer;

begin

 s := 1;

 for k := 3 to 6 do

   s := s * k;

 write(s);

end.


 


9
Задание 0 № 5360

Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трех языках программирования.

Алгоритмический

язык

алг

нач

  цел s,k

  s := 100

  нц для k от 0 до 10

    s := s - 5

  кц

  вывод s

кон

Бейсик

DIM s, k AS INTEGER

s  =  100

FOR k = 0 TO 10

  s = s – 5

NEXT k

PRINT s

END

Паскаль

var s, k:integer;

begin

  s := 100;

  for k := 0 to 10 do

  s := s - 5;

  writeln (s);

end.


 


10
Задание 0 № 5438

Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трех языках программирования.

 

Алгоритмический язык

алг

нач

   цел k,i

   k := 2

   нц для i от 0 до 2

         k := 3 * k + i

   кц

   вывод k

кон

Бейсик

DIM i,k AS INTEGER

k = 2

FOR i = 0 TO 2

  k = 3 * k + i

NEXT i

PRINT k

END

Паскаль

var k,i: integer;

begin

  k := 2;

  for i := 0 to 2 do

     k := 3 * k + i;

  writeln(k);

end.


 

 


11
Задание 0 № 5461

Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трех языках программирования.

 

Алгоритмический язык

алг

нач

  цел s, k

  s := 0

  нц для k от 2 до 12

    s := s + 11

  кц

  вывод s

кон

Бейсик

DIM s, k AS INTEGER

s  =  0

FOR k = 2 TO 12

  s = s + 11

NEXT k

PRINT s

END

Паскаль

var s, k:integer;

begin

  s := 0;

  for k := 2 to 12 do

    s := s + 11;

  writeln (s);

end.


 


12
Задание 0 № 5786

Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трех языках программирования.

Алгоритмический язык

алг

нач

цел  n, s

s := 2

нц для n от 2 до 5

s := n + s * 2

кц

вывод s

кон

Бейсик

DIM n, s AS INTEGER

s = 2

FOR n = 2 TO 5

  s = n + s * 2

NEXT n

PRINT s

END

Паскаль

var s, n: integer;

begin

s := 2;

for n := 2 to 5 do

s := n + s * 2;

write(s);

end.


 


13
Задание 0 № 5866

Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трех языках программирования.

 

Алгоритмический язык

алг

нач

  цел s, n

  s := 5

  нц для n от 2 до 4

      s := s + (n - 1)

  кц

  вывод s

кон

Бейсик

DIM s, n AS INTEGER

s = 5

FOR n = 2 TO 4

  s = s + (n - 1)

NEXT n

PRINT s

END

Паскаль

var s,n: integer;

begin

  s := 5;

  for n := 2 to 4 do

     s := s + (n - 1);

  writeln(s);

end.


 


14
Задание 0 № 5929

Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трех языках программирования.

Алгоритмический язык

алг

нач

цел  n, s

s := 1

нц для n от 3 до 8

s := s * 2

кц

вывод s

кон

Бейсик

DIM n, s AS INTEGER

s = 1

FOR n = 3 TO 8

  s = s * 2

NEXT n

PRINT s

END

Паскаль

var s, n: integer;

begin

s := 1;

for n := 3 to 8 do

s := s * 2;

write(s);

end.


 


15
Задание 0 № 5980

Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трех языках программирования.

Алгоритмический язык

алг

нач

цел  a, k

a := 4

нц для k от 5 до 8

a := a + 2 * k

кц

вывод a

кон

Бейсик

DIM a, k AS INTEGER

a = 4

FOR k = 5 TO 8

  a = a + 2 * k

NEXT k

PRINT a

END

Паскаль

var a, k : integer;

begin

a := 4;

for k := 5 to 8 do

a := a + 2 * k;

write(a);

end.


 


16
Задание 0 № 6126

Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трех языках программирования.

 

Алгоритмический язык

алг

нач

  цел k,i

  k := 4

  нц для i от 1 до 3

        k := 2 * k + i

  кц

  вывод k

кон

Бейсик

DIM i,k AS INTEGER

k = 4

FOR i = 1 TO 3

  k = 2 * k + i

NEXT i

PRINT k

END

Паскаль

var k,i: integer;

begin

  k := 4;

  For i := 1 to 3 do

     k := 2 * k + i;

  Writeln(k);

end.


 


17
Задание 0 № 6244

Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трех языках программирования.

 

Алгоритмический язык

алг

нач

  цел s, k

  s := 0

  нц для k от 2 до 9

    s := s + 2 * k

  кц

  вывод s

кон

Бейсик

DIM s, k AS INTEGER

s = 0

FOR k = 2 TO 9

  s = s + 2 * k

NEXT k

PRINT s

END

Паскаль

var s, k: integer;

begin

  s := 0;

  for k := 2 to 9 do

    s := s + 2 * k;

  write(s);

end.


 


18
Задание 0 № 6300

Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трех языках программирования.

 

Алгоритмический язык

алг

нач

   цел y,i

   y := 5

   нц для i от 1 до 3

         y := y + 5 * i

   кц

   вывод y

кон

Бейсик

DIM i,y AS INTEGER

y = 5

FOR i = 1 TO 3

  y = y + 5 * i

NEXT i

PRINT y

END

Паскаль

var y,i: integer;

begin

  y := 5;

  for i := 1 to 3 do

    y := y + 5 * i;

  writeln(y);

end.