СДАМ ГИА: РЕШУ ОГЭ
Образовательный портал для подготовки к экзаменам
Информатика
информатика
сайты - меню - вход - новости


Задания
Версия для печати и копирования в MS Word
Задание 0 № 5980

Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трех языках программирования.

Алгоритмический язык

алг

нач

цел  a, k

a := 4

нц для k от 5 до 8

a := a + 2 * k

кц

вывод a

кон

Бейсик

DIM a, k AS INTEGER

a = 4

FOR k = 5 TO 8

  a = a + 2 * k

NEXT k

PRINT a

END

Паскаль

var a, k : integer;

begin

a := 4;

for k := 5 to 8 do

a := a + 2 * k;

write(a);

end.


 

Решение.

Это задание ещё не решено, приводим решение прототипа.


Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на пяти языках программирования.

 

БейсикPython

DIM k, s AS INTEGER

s = 1

FOR k = 1 TO 5

    s = s * k

NEXT k

PRINT s

s = 1

for k in range(1,6):

    s = s * k

print (s)

ПаскальАлгоритмический язык

var s,k: integer;

begin

    s := 1;

    for k := 1 to 5 do

        s := s * k;

    writeln(s);

end.

алг

нач

   цел s, k

   s := 1

   нц для k от 1 до 5

      s := s * k

   кц

   вывод s

кон

С++

#include <iostream>

using namespace std;

int main() {

     int s = 1;

     for (int k = 1; k <= 5; k++)

          s = s * k;

     cout << s;

     return 0;

}

 



Цикл for k := 1 to 5 do вы­пол­нит­ся 5 раз. Каж­дый раз пе­ре­мен­ная s умножается на k. По­сколь­ку из­на­чаль­но зна­че­ние s равно 1, после вы­пол­не­ния про­грам­мы по­лу­чим s = 1 · 1 · 2 · 3 · 4 · 5 = 120.

 

Ответ: 120.

Прототип задания ·