СДАМ ГИА: РЕШУ ОГЭ
Образовательный портал для подготовки к экзаменам
Информатика
информатика
сайты - меню - вход - новости


Задания
Версия для печати и копирования в MS Word
Задание 0 № 5185

Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трех языках программирования.

Алгоритмический язык

алг

нач

цел  n, s

s := 1

нц для n от 5 до 8

s := s * 3

кц

вывод s

кон

Бейсик

DIM n, s AS INTEGER

s = 1

FOR n = 5 TO 8

  s = s * 3

NEXT n

PRINT s

END

Паскаль

var s, n: integer;

begin

s := 1;

for n := 5 to 8 do

s := s * 3;

write(s);

end.


 

Решение.

Это задание ещё не решено, приводим решение прототипа.


Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на пяти языках программирования.

 

БейсикPython

DIM k, s AS INTEGER

s = 1

FOR k = 1 TO 5

    s = s * k

NEXT k

PRINT s

s = 1

for k in range(1,6):

    s = s * k

print (s)

ПаскальАлгоритмический язык

var s,k: integer;

begin

    s := 1;

    for k := 1 to 5 do

        s := s * k;

    writeln(s);

end.

алг

нач

   цел s, k

   s := 1

   нц для k от 1 до 5

      s := s * k

   кц

   вывод s

кон

С++

#include <iostream>

using namespace std;

int main() {

     int s = 1;

     for (int k = 1; k <= 5; k++)

          s = s * k;

     cout << s;

     return 0;

}

 



Цикл for k := 1 to 5 do выполнится 5 раз. Каждый раз переменная s умножается на k. Поскольку изначально значение s равно 1, после выполнения программы получим s = 1 · 1 · 2 · 3 · 4 · 5 = 120.

 

Ответ: 120.

Прототип задания ·