СДАМ ГИА: РЕШУ ОГЭ
Образовательный портал для подготовки к экзаменам
Информатика
информатика
сайты - меню - вход - новости


Задания
Версия для печати и копирования в MS Word
Задание 0 № 5866

Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трех языках программирования.

 

Алгоритмический язык

алг

нач

  цел s, n

  s := 5

  нц для n от 2 до 4

      s := s + (n - 1)

  кц

  вывод s

кон

Бейсик

DIM s, n AS INTEGER

s = 5

FOR n = 2 TO 4

  s = s + (n - 1)

NEXT n

PRINT s

END

Паскаль

var s,n: integer;

begin

  s := 5;

  for n := 2 to 4 do

     s := s + (n - 1);

  writeln(s);

end.


 

Решение.

Это задание ещё не решено, приводим решение прототипа.


Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на пяти языках программирования.

 

БейсикPython

DIM k, s AS INTEGER

s = 1

FOR k = 1 TO 5

    s = s * k

NEXT k

PRINT s

s = 1

for k in range(1,6):

    s = s * k

print (s)

ПаскальАлгоритмический язык

var s,k: integer;

begin

    s := 1;

    for k := 1 to 5 do

        s := s * k;

    writeln(s);

end.

алг

нач

   цел s, k

   s := 1

   нц для k от 1 до 5

      s := s * k

   кц

   вывод s

кон

С++

#include <iostream>

using namespace std;

int main() {

     int s = 1;

     for (int k = 1; k <= 5; k++)

          s = s * k;

     cout << s;

     return 0;

}

 



Цикл for k := 1 to 5 do выполнится 5 раз. Каждый раз переменная s умножается на k. Поскольку изначально значение s равно 1, после выполнения программы получим s = 1 · 1 · 2 · 3 · 4 · 5 = 120.

 

Ответ: 120.

Прототип задания ·