СДАМ ГИА: РЕШУ ОГЭ
Образовательный портал для подготовки к экзаменам
Информатика
информатика
сайты - меню - вход - новости


Задания
Версия для печати и копирования в MS Word
Задание 0 № 6131

Исполнитель Черепашка перемещается на экране компьютера, оставляя след в виде линии. В каждый конкретный момент известно положение исполнителя и направление его движения. У исполнителя существует две команды:

Вперёд n (где n − целое число), вызывающая передвижение Черепашки на
n шагов в направлении движения;

Направо m (где m − целое число), вызывающая изменение направления движения на m градусов по часовой стрелке.

Запись Повтори k [Команда1 Команда2 Команда3] означает, что последовательность команд в скобках повторится k раз.

 

Черепашке был дан для исполнения следующий алгоритм:

Повтори 5 [Вперёд 100 Направо 120]

Какая фигура появится на экране?

   1) 

правильный пятиугольник

   2) 

правильный треугольник

   3) 

правильный шестиугольник

   4) 

незамкнутая ломаная линия

Решение.

Это задание ещё не решено, приводим решение прототипа.


Исполнитель Черепашка перемещается на экране компьютера, оставляя след в виде линии. В каждый конкретный момент известно положение исполнителя и направление его движения. У исполнителя существуют две команды:

Вперёд n (где n − целое число), вызывающая передвижение Черепашки на n шагов в направлении движения.

Направо m (где m − целое число), вызывающая изменение направления движения на m градусов по часовой стрелке.

 

Запись Повтори k [Команда1 Команда2] означает, что последовательность команд в скобках повторится k раз.

 

Черепашке был дан для исполнения следующий алгоритм:

Повтори 6 [Направо 45 Вперёд 20 Направо 45]

Какая фигура появится на экране?

1) правильный шестиугольник

2) правильный восьмиугольник

3) квадрат

4) незамкнутая ломаная линия

Выполняя алгоритм, Черепашка оставляет след в виде одинаковых отрезков, расположенных под углом 180° − 45° − 45° = 90° друг к другу. Стороны квадрата составляют между собой угол в 90°. Поэтому через 6 шагов алгоритма Черепашка нарисует квадрат.

 

Примечание:

Сумма внутренних углов выпуклого n-угольника равна 180°(n − 2), поэтому угол между его сторонами может быть найден по формуле 180°(1 − 2/n).

 

Правильный ответ указан под номером 3.

Прототип задания ·