СДАМ ГИА: РЕШУ ОГЭ
Образовательный портал для подготовки к экзаменам
Информатика
информатика
сайты - меню - вход - новости


Задания
Версия для печати и копирования в MS Word
Задание 0 № 5813

Исполнитель Черепашка перемещается на экране компьютера, оставляя след в виде линии. В  каждый  конкретный  момент  известно  положение исполнителя и  направление его движения. У исполнителя существуют две команды:

Вперёд n (где n − целое  число),  вызывающая  передвижение Черепашки на n шагов в направлении движения;

Направо m  (где  m −  целое  число),  вызывающая изменение направления движения на m градусов по часовой стрелке.

Запись Повтори  k [Команда1  Команда2  Команда3] означает, что последовательность команд в скобках повторится k раз.

 

Черепашке был дан для исполнения следующий алгоритм рисования правильного шестиугольника:

Повтори 3 [Направо 60 Вперёд 50 *** Вперёд 50]

Какая команда должна быть в алгоритме вместо ***?

 

   1) 

Вперед 30

   2) 

Вперед 60

   3) 

Направо 30

   4) 

Направо 60

Решение.

Это задание ещё не решено, приводим решение прототипа.


Исполнитель Черепашка перемещается на экране компьютера, оставляя след в виде линии. В каждый конкретный момент известно положение исполнителя и направление его движения. У исполнителя существуют две команды:

Вперёд n (где n − целое число), вызывающая передвижение Черепашки на n шагов в направлении движения.

Направо m (где m − целое число), вызывающая изменение направления движения на m градусов по часовой стрелке.

 

Запись Повтори k [Команда1 Команда2] означает, что последовательность команд в скобках повторится k раз.

 

Черепашке был дан для исполнения следующий алгоритм:

Повтори 6 [Направо 45 Вперёд 20 Направо 45]

Какая фигура появится на экране?

1) правильный шестиугольник

2) правильный восьмиугольник

3) квадрат

4) незамкнутая ломаная линия

Вы­пол­няя ал­го­ритм, Че­ре­паш­ка остав­ля­ет след в виде оди­на­ко­вых от­рез­ков, рас­по­ло­жен­ных под углом 180° − 45° − 45° = 90° друг к другу. Сто­ро­ны квад­ра­та со­став­ля­ют между собой угол в 90°. По­это­му через 6 шагов ал­го­рит­ма Че­ре­паш­ка на­ри­су­ет квадрат.

 

Примечание:

Сумма внут­рен­них углов вы­пук­ло­го n-угольника равна 180°(n − 2), по­это­му угол между его сто­ро­на­ми может быть най­ден по фор­му­ле 180°(1 − 2/n).

 

Правильный ответ указан под номером 3.

Прототип задания ·