СДАМ ГИА: РЕШУ ОГЭ
Образовательный портал для подготовки к экзаменам
Информатика
информатика
сайты - меню - вход - новости


Задания
Версия для печати и копирования в MS Word
Задание 9 № 309

За­пи­ши­те зна­че­ние пе­ре­мен­ной s, по­лу­чен­ное в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей про­грам­мы. Текст про­грам­мы при­ведён на пяти язы­ках про­грам­ми­ро­ва­ния.

 

Бей­сикPython

DIM k, s AS INTEGER

s = 0

FOR k = 13 TO 16

    s = s + 14

NEXT k

PRINT s

s = 0

for k in range(13,17):

    s = s + 14

print (s)

Пас­кальАл­го­рит­ми­че­ский язык

var s,k: integer;

begin

    s := 0;

    for k := 13 to 16 do

        s := s + 14;

    writeln(s);

end.

алг

нач

   цел s, k

   s := 0

   нц для k от 13 до 16

      s := s + 14

   кц

   вывод s

кон

С++

#include <iostream>

using namespace std;

int main() {

     int s = 0;

     for (int k = 13; k <= 16; k++)

          s += 14;

     cout << s;

     return 0;

}

 

Ре­ше­ние.

Цикл «for k := 13 to 16 do» вы­пол­ня­ет­ся че­ты­ре раза. Каж­дый раз пе­ре­мен­ная s уве­ли­чи­ва­ет­ся на 14. По­сколь­ку из­на­чаль­но s = 0, после вы­пол­не­ния про­грам­мы по­лу­чим: s = 4 · 14 = 56.

Источник: ГИА по информатике 31.05.2013. Основная волна. Вариант 1316.