№№ заданий Пояснения Ответы Ключ Добавить инструкцию Критерии
Источник Раздел кодификатора ФИ­ПИ
PDF-версия PDF-версия (вертикальная) PDF-версия (крупный шрифт) PDF-версия (с большим полем) Версия для копирования в MS Word
Задания
Задания Д8 № 309

Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на пяти языках программирования.

 

БейсикPython

DIM k, s AS INTEGER

s = 0

FOR k = 13 TO 16

    s = s + 14

NEXT k

PRINT s

s = 0

for k in range(13,17):

    s = s + 14

print (s)

ПаскальАлгоритмический язык

var s,k: integer;

begin

    s := 0;

    for k := 13 to 16 do

        s := s + 14;

    writeln(s);

end.

алг

нач

   цел s, k

   s := 0

   нц для k от 13 до 16

      s := s + 14

   кц

   вывод s

кон

С++

#include <iostream>

using namespace std;

int main() {

     int s = 0;

     for (int k = 13; k <= 16; k++)

          s += 14;

     cout << s;

     return 0;

}

 

Решение.

Цикл «for k := 13 to 16 do» выполняется четыре раза. Каждый раз переменная s увеличивается на 14. Поскольку изначально s = 0, после выполнения программы получим: s = 4 · 14 = 56.