информатика
Математика
Информатика
Английский язык
Немецкий язык
Французcкий язык
Испанский язык
Физика
Химия
Биология
География
Обществознание
Литература
История
сайты - меню - вход - новости




Каталог заданий.
Задания 9. Простейший циклический алгоритм, записанный на алгоритмическом языке
Сортировка:
Пройти тестирование по этим заданиям
Вернуться к каталогу заданий
Версия для печати и копирования в MS Word
1
Задание 9 № 9

Запишите зна­че­ние переменной s, по­лу­чен­ное в ре­зуль­та­те работы сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль
алг

нач

цел s, k

s := 0

нц для k от 3 до 7

s := s + 6

кц

вывод s

кон

DIM k, s AS INTEGER

s = 0

FOR к = 3 TO 7

s = s + 6

NEXT k

PRINT s

Var s,k: integer;

Begin

s := 0;

for k := 3 to 7 do

s := s + 6;

writeln(s);

End.

Источник: ГИА по информатике 31.05.2013. Основная волна. Центр, Урал. Вариант 1301.

2
Задание 9 № 29

Запишите зна­че­ние переменной s, по­лу­чен­ное в ре­зуль­та­те работы сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль
алг

нач

цел s, k

s := 0

нц для k от 4 до 8

s := s + 7

кц

вывод s

кон

DIM k, s AS INTEGER

s = 0

FOR к = 4 TO 8

s = s + 7

NEXT k

PRINT s

Var s,k: integer;

Begin

s := 0;

for k := 4 to 8 do

s := s + 7;

writeln(s);

End.

Источник: ГИА по информатике 31.05.2013. Основная волна. Центр, Урал. Вариант 1302.

3
Задание 9 № 49

Запишите зна­че­ние переменной s, по­лу­чен­ное в ре­зуль­та­те работы сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль
алг

нач

цел s, k

s := 0

нц для k от 4 до 7

s := s + 8

кц

вывод s

кон

DIM k, s AS INTEGER

s = 0

FOR к = 4 TO 7

s = s + 8

NEXT k

PRINT s

Var s,k: integer;

Begin

s := 0;

for k := 4 to 7 do

s := s + 8;

writeln(s);

End.

Источник: ГИА по информатике 31.05.2013. Основная волна. Центр, Урал. Вариант 1303.

4
Задание 9 № 69

Запишите зна­че­ние переменной s, по­лу­чен­ное в ре­зуль­та­те работы сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль
алг

нач

цел s, k

s := 0

нц для k от 3 до 8

s := s + 9

кц

вывод s

кон

DIM k, s AS INTEGER

s = 0

FOR к = 3 TO 8

s = s + 9

NEXT k

PRINT s

Var s,k: integer;

Begin

s := 0;

for k := 3 to 8 do

s := s + 9;

writeln(s);

End.

Источник: ГИА по информатике 31.05.2013. Основная волна. Центр, Урал. Вариант 1304.

5
Задание 9 № 89

Запишите зна­че­ние переменной s, по­лу­чен­ное в ре­зуль­та­те работы сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль
алг

нач

цел s, k

s := 0

нц для k от 3 до 8

s := s + 7

кц

вывод s

кон

DIM k, s AS INTEGER

s = 0

FOR к = 3 TO 8

s = s + 7

NEXT k

PRINT s

Var s,k: integer;

Begin

s := 0;

for k := 3 to 8 do

s := s + 7;

writeln(s);

End.

Источник: ГИА по информатике 31.05.2013. Основная волна. Сибирь, Даль­ний Восток. Вариант 1305.

6
Задание 9 № 109

Запишите зна­че­ние пе­ре­мен­ной s, по­лу­чен­ное в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль
алг

нач

цел s, k

s := 0

нц для k от 3 до 8

s := s + 6

кц

вывод s

кон

DIM k, s AS INTEGER

s = 0

FOR к = 3 TO 8

s = s + 6

NEXT k

PRINT s

Var s,k: integer;

Begin

s := 0;

for k := 3 to 8 do

s := s + 6;

writeln(s);

End.

Источник: ГИА по информатике 31.05.2013. Основная волна. Сибирь, Даль­ний Восток. Вариант 1306.

7
Задание 9 № 129

Запишите зна­че­ние переменной s, по­лу­чен­ное в ре­зуль­та­те работы сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль
алг

нач

цел s, k

s := 0

нц для k от 5 до 9

s := s + 8

кц

вывод s

кон

DIM k, s AS INTEGER

s = 0

FOR к = 5 TO 9

s = s + 8

NEXT k

PRINT s

Var s,k: integer;

Begin

s := 0;

for k := 5 to 9 do

s := s + 8;

writeln(s);

End.

Источник: ГИА по информатике 31.05.2013. Основная волна. Сибирь, Даль­ний Восток. Вариант 1307.

8
Задание 9 № 149

Запишите зна­че­ние переменной s, по­лу­чен­ное в ре­зуль­та­те работы сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль
алг

нач

цел s, k

s := 0

нц для k от 6 до 10

s := s + 10

кц

вывод s

кон

DIM k, s AS INTEGER

s = 0

FOR к = 6 TO 10

s = s + 10

NEXT k

PRINT s

Var s,k: integer;

Begin

s := 0;

for k := 6 to 10 do

s := s + 10;

writeln(s);

End.

Источник: ГИА по информатике 31.05.2013. Основная волна. Вариант 1308.

9
Задание 9 № 169

Запишите зна­че­ние переменной s, по­лу­чен­ное в ре­зуль­та­те работы сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль
алг

нач

цел s, k

s := 0

нц для k от 7 до 11

s := s + 11

кц

вывод s

кон

DIM k, s AS INTEGER

s = 0

FOR к = 7 TO 11

s = s + 11

NEXT k

PRINT s

Var s,k: integer;

Begin

s := 0;

for k := 7 to 11 do

s := s + 11;

writeln(s);

End.

Источник: ГИА по информатике 31.05.2013. Основная волна. Вариант 1309.

10
Задание 9 № 189

Запишите зна­че­ние переменной s, по­лу­чен­ное в ре­зуль­та­те работы сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль
алг

нач

цел s, k

s := 0

нц для k от 8 до 12

s := s + 12

кц

вывод s

кон

DIM k, s AS INTEGER

s = 0

FOR к = 8 TO 12

s = s + 12

NEXT k

PRINT s

Var s,k: integer;

Begin

s := 0;

for k := 8 to 12 do

s := s + 12;

writeln(s);

End.

Источник: ГИА по информатике 31.05.2013. Основная волна. Вариант 1310.

11
Задание 9 № 209

Запишите зна­че­ние переменной s, по­лу­чен­ное в ре­зуль­та­те работы сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль
алг

нач

цел s, k

s := 0

нц для k от 9 до 13

s := s + 9

кц

вывод s

кон

DIM k, s AS INTEGER

s = 0

FOR к = 9 TO 13

s = s + 9

NEXT k

PRINT s

Var s,k: integer;

Begin

s := 0;

for k := 9 to 13 do

s := s + 9;

writeln(s);

End.

Источник: ГИА по информатике 31.05.2013. Основная волна. Вариант 1311.

12
Задание 9 № 229

Запишите зна­че­ние переменной s, по­лу­чен­ное в ре­зуль­та­те работы сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль
алг

нач

цел s, k

s := 0

нц для k от 6 до 9

s := s + 12

кц

вывод s

кон

DIM k, s AS INTEGER

s = 0

FOR к = 6 TO 9

s = s + 12

NEXT k

PRINT s

Var s,k: integer;

Begin

s := 0;

for k := 6 to 9 do

s := s + 12;

writeln(s);

End.

Источник: ГИА по информатике 31.05.2013. Основная волна. Вариант 1312.

13
Задание 9 № 249

Запишите зна­че­ние переменной s, по­лу­чен­ное в ре­зуль­та­те работы сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль
алг

нач

цел s, k

s := 0

нц для k от 7 до 12

s := s + 11

кц

вывод s

кон

DIM k, s AS INTEGER

s = 0

FOR к = 7 TO 12

s = s + 11

NEXT k

PRINT s

Var s,k: integer;

Begin

s := 0;

for k := 7 to 12 do

s := s + 11;

writeln(s);

End.

Источник: ГИА по информатике 31.05.2013. Основная волна. Вариант 1313.

14
Задание 9 № 269

Запишите зна­че­ние переменной s, по­лу­чен­ное в ре­зуль­та­те работы сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль
алг

нач

цел s, k

s := 0

нц для k от 6 до 12

s := s + 10

кц

вывод s

кон

DIM k, s AS INTEGER

s = 0

FOR к = 6 TO 12

s = s + 10

NEXT k

PRINT s

Var s,k: integer;

Begin

s := 0;

for k := 6 to 12 do

s := s + 10;

writeln(s);

End.

Источник: ГИА по информатике 31.05.2013. Основная волна. Вариант 1314.

15
Задание 9 № 289

Запишите зна­че­ние переменной s, по­лу­чен­ное в ре­зуль­та­те работы сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль
алг

нач

цел s, k

s := 0

нц для k от 12 до 15

s := s + 13

кц

вывод s

кон

DIM k, s AS INTEGER

s = 0

FOR к = 12 TO 15

s = s + 13

NEXT k

PRINT s

Var s,k: integer;

Begin

s := 0;

for k := 12 to 15 do

s := s + 13;

writeln(s);

End.

Источник: ГИА по информатике 31.05.2013. Основная волна. Вариант 1315.

16
Задание 9 № 309

Запишите зна­че­ние переменной s, по­лу­чен­ное в ре­зуль­та­те работы сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль
алг

нач

цел s, k

s := 0

нц для k от 13 до 16

s := s + 14

кц

вывод s

кон

DIM k, s AS INTEGER

s = 0

FOR к = 13 TO 16

s = s + 14

NEXT k

PRINT s

Var s,k: integer;

Begin

s := 0;

for k := 13 to 16 do

s := s + 14;

writeln(s);

End.

Источник: ГИА по информатике 31.05.2013. Основная волна. Вариант 1316.

17
Задание 9 № 329

Запишите зна­че­ние переменной s, по­лу­чен­ное в ре­зуль­та­те работы сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль
алг

нач

цел s, k

s := 8

нц для k от 3 до 8

s := s + 8

кц

вывод s

кон

DIM k, s AS INTEGER

s = 8

FOR к = 3 TO 8

s = s + 8

NEXT k

PRINT s

Var s,k: integer;

Begin

s := 8;

for k := 3 to 8 do

s := s + 8;

writeln(s);

End.

Источник: Демонстрационная вер­сия ГИА—2013 по информатике.

18
Задание 9 № 350

Запишите зна­че­ние пе­ре­мен­ной s, по­лу­чен­ное в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль
алг

нач

цел s, k

s := 50

нц для k от 0 до 8

s := s - 4

кц

вывод s

кон

DIM k, s AS INTEGER

s = 50

FOR к = 0 TO 8

s = s - 4

NEXT k

PRINT s

END

Var s,k: integer;

Begin

s := 50;

for k := 0 to 8 do

s := s - 4;

writeln(s);

End.

Источник: Типовые эк­за­ме­на­ци­он­ные варианты. Кры­лов С. С., Чур­ки­на Т. Е. — 2013, ва­ри­ант 1.

19
Задание 9 № 370

Определите, что будет на­пе­ча­та­но в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль
алг

нач

цел s, k

s := 50

нц для k от 1 до 9

s := s - 3

кц

вывод s

кон

s = 50

FOR к = 1 TO 9

s = s - 3

NEXT k

PRINT s

END

Var s, k: integer;

Begin

s := 50;

for k := 1 to 9 do

s := s - 3;

write (s);

End.

Источник: Типовые эк­за­ме­на­ци­он­ные ва­ри­ан­ты по информатике. Кры­лов С. С., Чур­ки­на Т. Е. — 2013, ва­ри­ант 2.

20
Задание 9 № 390

Определите, что будет на­пе­ча­та­но в ре­зуль­та­те работы сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль
алг

нач

цел s, k

s := 100

нц для k от 1 до 9

s := s - 5

кц

вывод s

кон

DIM k, s AS INTEGER

s = 100

FOR k = 1 TO 9

s = s - 5

NEXT k

PRINT s

END

Var s, k: integer;

Begin

s := 100;

for k := 1 to 9 do

s := s - 5;

write (s);

End.

Источник: Типовые эк­за­ме­на­ци­он­ные ва­ри­ан­ты по информатике. Кры­лов С. С., Чур­ки­на Т. Е. — 2013, ва­ри­ант 3.

21
Задание 9 № 410

Определите, что будет на­пе­ча­та­но в ре­зуль­та­те работы сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль
алг

нач

цел s, k

s := 3

нц для k от 0 до 9

s := s + 3

кц

вывод s

кон

s = 3

FOR к = 0 TO 9

s = s + 3

NEXT k

PRINT s

END

Var s, k: integer;

Begin

s := 3;

for k := 0 to 9 do

s := s + 3;

write (s);

End.

Источник: Типовые эк­за­ме­на­ци­он­ные ва­ри­ан­ты по информатике. Кры­лов С. С., Чур­ки­на Т. Е. — 2013, ва­ри­ант 4.

22
Задание 9 № 430

Определите, что будет на­пе­ча­та­но в ре­зуль­та­те работы сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль
алг

нач

цел s, k

s := 1

нц для k от 0 до 9

s := s + 5

кц

вывод s

кон

s = 1

FOR к = 0 TO 9

s = s + 5

NEXT k

PRINT s

END

Var s, k: integer;

Begin

s := 1;

for k := 0 to 9 do

s := s + 5;

write (s);

End.

Источник: Типовые эк­за­ме­на­ци­он­ные ва­ри­ан­ты по информатике. Кры­лов С. С., Чур­ки­на Т. Е. — 2013, ва­ри­ант 5.

23
Задание 9 № 450

Определите, что будет на­пе­ча­та­но в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль
алг

нач

цел s, k

s := 2

нц для k от 1 до 3

s := s*s

кц

вывод s

кон

s = 2

FOR к = 1 TO 3

s = s*s

NEXT k

PRINT s

END

Var s, k: integer;

Begin

s := 2;

for k := 1 to 3 do

s := s*s;

write (s);

End.

Источник: Типовые эк­за­ме­на­ци­он­ные ва­ри­ан­ты по информатике. Кры­лов С. С., Чур­ки­на Т. Е. — 2013, ва­ри­ант 6.

24
Задание 9 № 470

Определите, что будет на­пе­ча­та­но в ре­зуль­та­те работы сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль
алг

нач

цел s, k

s := 1

нц для k от 3 до 0

шаг −1

s := s*3

кц

вывод s

кон

s = 1

FOR k = 3 TO 0

STEP −1

s = s*3

NEXT k

PRINT s

END

Var s, k: integer;

Begin

s := 1;

for k := 3 downto 0 do

s := s*3;

write (s);

End.

Источник: Типовые эк­за­ме­на­ци­он­ные ва­ри­ан­ты по информатике. Кры­лов С. С., Чур­ки­на Т. Е. — 2013, ва­ри­ант 7.

25
Задание 9 № 490

Определите, что будет на­пе­ча­та­но в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль
алг

нач

цел s, k

s := 2

нц для k от 1 до 5

s := s*2

кц

вывод s

кон

s = 2

FOR k = 1 TO 5

s = s*2

NEXT k

PRINT s

END

Var s, k: integer;

Begin

s := 2;

for k := 1 to 5 do

s := s*2;

write (s);

End.

Источник: Типовые эк­за­ме­на­ци­он­ные ва­ри­ан­ты по информатике. Кры­лов С. С., Чур­ки­на Т. Е. — 2013, ва­ри­ант 8.

26
Задание 9 № 510

Определите, что будет на­пе­ча­та­но в ре­зуль­та­те работы сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль
алг

нач

цел s, k

s := 1

нц для k от 0 до 4

s := s*3

кц

вывод s

кон

s = 1

FOR k = 0 TO 4

s = s*3

NEXT k

PRINT s

END

Var s, k: integer;

Begin

s := 1;

for k := 0 to 4 do

s := s*3;

write (s);

End.

Источник: Типовые эк­за­ме­на­ци­он­ные ва­ри­ан­ты по информатике. Кры­лов С. С., Чур­ки­на Т. Е. — 2013, ва­ри­ант 9.

27
Задание 9 № 530

Определите, что будет на­пе­ча­та­но в ре­зуль­та­те работы сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль
алг

нач

цел s, k

s := 1

нц для k от 1 до 7

s := s*2

кц

вывод s

кон

s = 1

FOR k = 1 TO 7

s = s*2

NEXT k

PRINT s

END

Var s, k: integer;

Begin

s := 1;

for k := 1 to 7 do

s := s*2;

write (s);

End.

Источник: Типовые эк­за­ме­на­ци­он­ные ва­ри­ан­ты по информатике. Кры­лов С. С., Чур­ки­на Т. Е. — 2013, ва­ри­ант 10.

28
Задание 9 № 550

Запишите зна­че­ние переменной y, по­лу­чен­ное в ре­зуль­та­те работы сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль
алг

нач

цел y, i

y := 0

нц для i от 1 до 3

y := y + 4*i

кц

вывод y

кон

DIM i, y AS INTEGER

y = 0

FOR i = 1 TO 3

y = y + 4*i

NEXT i

PRINT y

Var y,i: integer;

Begin

y := 0;

For i := 1 to 3 do

y := y + 4*i;

Writeln(y);

End.


29
Задание 9 № 570

Запишите зна­че­ние пе­ре­мен­ной y, по­лу­чен­ное в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль
алг

нач

цел y, i

y := 5

нц для i от 1 до 3

y := y + 5*i

кц

вывод y

кон

DIM i, y AS INTEGER

y = 5

FOR i = 1 TO 3

y = y + 5*i

NEXT i

PRINT y

Var y,i: integer;

Begin

y := 5;

For i := 1 to 3 do

y := y + 5*i;

Writeln(y);

End.


30
Задание 9 № 590

Запишите зна­че­ние переменной k, по­лу­чен­ное в ре­зуль­та­те работы сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль
алг

нач

цел k, i

k := 4

нц для i от 1 до 3

k := i + 2*k

кц

вывод k

кон

DIM i, k AS INTEGER

k = 4

FOR i = 1 TO 3

k = i + 2*k

NEXT i

PRINT k

Var k, i: integer;

Begin

k := 4;

For i := 1 to 3 do

k := i + 2*k;

Writeln(k);

End.


31
Задание 9 № 610

Запишите зна­че­ние переменной k, по­лу­чен­ное в ре­зуль­та­те работы сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль
алг

нач

цел k, i

k := 2

нц для i от 0 до 2

k := i + 3*k

кц

вывод k

кон

DIM i, k AS INTEGER

k = 2

FOR i = 0 TO 2

k = i + 3*k

NEXT i

PRINT k

Var k, i: integer;

Begin

k := 2;

For i := 0 to 2 do

k := i + 3*k;

Writeln(k);

End.


32
Задание 9 № 630

Запишите зна­че­ние переменной s, по­лу­чен­ное в ре­зуль­та­те работы сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль
алг

нач

цел s, i

s := 3

нц для i от 2 до 5

s := s + 2*i

кц

вывод s

кон

DIM i, s AS INTEGER

s = 3

FOR i = 2 TO 5

s = s + 2*i

NEXT i

PRINT s

Var s, i: integer;

Begin

s := 3;

For i := 2 to 5 do

s := s + 2*i;

Writeln(s);

End.


33
Задание 9 № 650

Запишите зна­че­ние пе­ре­мен­ной s, по­лу­чен­ное в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль
алг

нач

цел s, n

s := 5

нц для n от 2 до 4

s := s + (n-1)

кц

вывод s

кон

DNM n, s AS INTEGER

s = 5

FOR n = 2 TO 4

s = s + (n-1)

NEXT n

PRINT s

Var s, n: integer;

Begin

s := 5;

For n := 2 to 4 do

s := s + (n-1);

Writeln(s);

End.


34
Задание 9 № 670

Запишите зна­че­ние пе­ре­мен­ной s, по­лу­чен­ное в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль
алг

нач

цел s, n

s := 2

нц для n от 2 до 5

s := s*2 + n

кц

вывод s

кон

DNM n, s AS INTEGER

s = 2

FOR n = 2 TO 5

s = s*2 + n

NEXT n

PRINT s

Var s, n: integer;

Begin

s := 2;

For n := 2 to 5 do

s := s*2 + n;

Writeln(s);

End.


35
Задание 9 № 690

Запишите зна­че­ние пе­ре­мен­ной s, по­лу­чен­ное в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль
алг

нач

цел s, n

s := 2

нц для n от 2 до 5

s := s + n*2

кц

вывод s

кон

DNM n, s AS INTEGER

s = 2

FOR n = 2 TO 5

s = s + n*2

NEXT n

PRINT s

Var s, n: integer;

Begin

s := 2;

For n := 2 to 5 do

s := s + n*2;

Writeln(s);

End.


36
Задание 9 № 710

Запишите зна­че­ние переменной s, по­лу­чен­ное в ре­зуль­та­те работы сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль
алг

нач

цел s, k

s := 0

нц для k от 6 до 12

s := s + 10

кц

вывод s

кон

DIM k, s AS INTEGER

s = 0

FOR к = 6 TO 12

s = s + 10

NEXT k

PRINT s

Var s,k: integer;

Begin

s := 0;

for k := 6 to 12 do

s := s + 10;

writeln(s);

End.

Источник: Демонстрационная вер­сия ГИА—2014 по информатике.

37
Задание 9 № 753

Запишите значение переменной d, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

 

Алгоритмический языкБейсикПаскаль

алг

нач

цел d,n

d := 6

d := d-2

нц для n от 1 до 4

d : = d + n

кц

вывод d

кон

DIM n,d AS INTEGER

d = 6

d = d-2

FOR n = 1 TO 4

d = d + n

NEXT n

PRINT d

Var d,n: integer;

Begin

d := 6;

d := d-2;

For n := 1 to 4 do

d : = d + n ;

Writeln(d);

End .


38
Задание 9 № 773

Запишите зна­че­ние пе­ре­мен­ной d, по­лу­чен­ное в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль

алг

нач

цел d,n

d := 5

d := d-3

нц для n от 1 до 4

d := d + n

кц

вывод d

кон

DIM n,d AS INTEGER

d = 5

d = d-3

FOR n = 1 TO 4

d = d + n

NEXT n

PRINT d

Var d,n: integer;

Begin

d := 5;

d := d-3;

For n := 1 to 4 do

d := d + n;

Writeln(d);

End.


39
Задание 9 № 805

Запишите зна­че­ние пе­ре­мен­ной f, по­лу­чен­ное в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль

алг

нач

цел f,n

f := 4

f := f*3

нц для n от 1 до 4

f := f + n

кц

вывод f

кон

DIM n,f AS INTEGER

f = 4

f = f*3

FOR n = 1 TO 4

f = f + n

NEXT n

PRINT f

Var f,n: integer;

Begin

f := 4;

f := f*3;

For n := 1 to 4 do

f := f + n;

Writeln(f);

End.


40
Задание 9 № 825

Запишите зна­че­ние пе­ре­мен­ной f, по­лу­чен­ное в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль

алг

нач

цел f,n

f := 22

f := f–20

нц для n от 1 до 5

f := f + n

кц

вывод f

кон

DIM n,f AS INTEGER

f = 22

f = f–20

FOR n = 1 TO 5

f = f + n

NEXT n

PRINT f

Var f,n: integer;

Begin

f := 22;

f := f–20;

For n := 1 to 5 do

f := f + n;

Writeln(f);

End.


41
Задание 9 № 847

Запишите зна­че­ние пе­ре­мен­ной s, по­лу­чен­ное в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль

алг

нач

цел n, s

s := 1

нц для n от 2 до 5

s := s * 3

кц

вывод s

кон

DIM n, s AS INTEGER

s = 1

FOR n = 2 TO 5

s = s * 3

NEXT n

PRINT s

END

var n, s: integer;

begin

s := 1;

for n := 2 to 5 do

s := s * 3;

write(s);

end.


42
Задание 9 № 867

Запишите зна­че­ние пе­ре­мен­ной s, по­лу­чен­ное в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль

алг

нач

цел n, s

s := 0

нц для n от 3 до 7

s := s + 2 * n

кц

вывод s

кон

DIM n, s AS INTEGER

s = 0

FOR n = 3 TO 7

s = s + 2 * n

NEXT n

PRINT s

END

var n, s: integer;

begin

s := 0;

for n := 3 to 7 do

s := s + 2 * n;

write(s);

end.


43
Задание 9 № 888

Запишите зна­че­ние пе­ре­мен­ной d, по­лу­чен­ное в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль

алг

нач

цел d,n,i

n :=4

d := n*2

нц для i от 1 до 3

d := d + 2*i

кц

вывод d

кон

DIM d,n,i AS INTEGER

n = 4

d = n*2

FOR i = 1 TO 3

d = d + 2*i

NEXT i

PRINT d

Var d,n,i:integer;

Begin

n := 4;

d := n*2;

For i := 1 to 3 do

d := d + 2*i;

Writeln(d);

End.


44
Задание 9 № 908

Запишите значение переменной d, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

 

Алгоритмический языкБейсикПаскаль

алг

нач

цел d,n,i

n :=3

d := n*3

нц для i от 1 до 3

d := d + i

кц

вывод d

кон

DIM d,n,i AS INTEGER

n = 3

d = n*3

FOR i = 1 TO 3

d = d + i

NEXT i

PRINT d

Var d,n,i: integer;

Begin

n := 3;

d := n*3;

For i := 1 to 3 do

d := d + i;

Writeln(d);

End.


45
Задание 9 № 928

Запишите зна­че­ние пе­ре­мен­ной t, по­лу­чен­ное в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль

алг

нач

цел t,i

t := 1

нц для i от 1 до 4

t := t * i

кц

вывод t

кон

DIM i,t AS INTEGER

t = 1

FOR i = 1 TO 4

t = t * i

NEXT i

PRINT t

Var t,i: integer;

Begin

t := 1;

For i := 1 to 4 do

t := t * i;

Writeln(t);

End.


46
Задание 9 № 948

Запишите зна­че­ние пе­ре­мен­ной t, по­лу­чен­ное в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль

алг

нач

цел t,i

t := 2

нц для i от 1 до 3

t := t * i

кц

вывод t

кон

DIM i,t AS INTEGER

t = 2

FOR i = 1 TO 3

t = t * i

NEXT i

PRINT t

Var t,i: integer;

Begin

t := 2;

For i := 1 to 3 do

t := t * i;

Writeln(t);

End.


47
Задание 9 № 1020

Запишите зна­че­ние пе­ре­мен­ной u, по­лу­чен­ное в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль

алг

нач

цел u,i

u := 30

нц для i от 1 до 6

u := u – i

кц

вывод u

кон

DIM i,u AS INTEGER

u = 30

FOR i = 1 TO 6

u = u – i

NEXT i

PRINT u

Var u,i: integer;

Begin

u := 30;

For i := 1 to 6 do

u := u – i;

Writeln(u);

End.


48
Задание 9 № 1040

Запишите зна­че­ние пе­ре­мен­ной u, по­лу­чен­ное в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль

алг

нач

цел u,i

u := 26

нц для i от 1 до 5

u := u – i

кц

вывод u

кон

DIM i,u AS INTEGER

u = 26

FOR i = 1 TO 5

u = u – i

NEXT i

PRINT u

Var u,i: integer;

Begin

u := 26;

For i := 1 to 5 do

u := u – i;

Writeln(u);

End.


49
Задание 9 № 1060

Определите, что будет на­пе­ча­та­но в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль

алг

нач

цел s, k

s:=0

нц для k от 3 до 10

s:=s+13

кц

вывод s

кон

DIM s,k AS INTEGER

s = 0

FOR k = 3 TO 10

s= s+13

NEXT k

PRINT s

END

Var s, k: integer;

Begin

s:=0;

for k:=3 to 10 do

s:=s+13;

write(s);

End.


50
Задание 9 № 1080

Определите, что будет на­пе­ча­та­но в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль

алг

нач

цел s, k

s := 8,

нц для k от 14 до 18

s := s+6

кц

вывод s

кон

DIM k, s AS INTEGER

s = 8

FOR k = 14 TO 18

s = s+6

NEXT k

PRINT s

Var s,k: integer;

Begin

s := 8;

for k := 14 to 18 do

s := s+6;

writeln(s);

End.


51
Задание 9 № 1103

Запишите зна­че­ние пе­ре­мен­ной s, по­лу­чен­ное в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль

алг

нач

цел s, k

s := 0

нц для k от 4 до 9

s := s + 12

кц

вывод s

кон

DIM k, s AS INTEGER

s = 0

FOR k = 4 TO 9

s = s + 12

NEXT k

PRINT s

Var s,k: integer;

Begin

s := 0;

for k := 4 to 9 do

s := s + 12;

writeln(s);

End.


52
Задание 9 № 1123

Запишите зна­че­ние пе­ре­мен­ной s, по­лу­чен­ное в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль

алг

нач

цел s, k

s := 0

нц для k от 2 до 12

s := s + 11

кц

вывод s

кон

DIM k, s AS INTEGER

s = 0

FOR k = 2 TO 12

s = s + 11

NEXT k

PRINT s

Var s,k: integer;

Begin

s := 0;

for k := 2 to 12 do

s := s + 11;

writeln(s);

End.


53
Задание 9 № 1143

Запишите зна­че­ние пе­ре­мен­ной s, по­лу­чен­ное в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль

алг

нач

цел s,k

s:=100

нц для k от 0 до 10

s:=s-5

кц

вывод s

кон

DIM s AS INTEGER

DIM k AS INTEGER

s = 100

FOR k = 0 TO 10

s = s – 5

NEXT k

PRINT s

END

var s, k:integer;

begin

s:= 100;

for k:= 0 to 10 do

s:= s - 5;

writeln (s);

end.


54
Задание 9 № 1163

Запишите зна­че­ние пе­ре­мен­ной s, по­лу­чен­ное в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль

алг

нач

цел s, k

s := 0

нц для k от 14 до 18

s := s+7

кц

вывод s

кон

DIM k, s AS INTEGER

s = 0

FOR k = 14 TO 18

s = s+7

NEXT k

PRINT s

Var s,k: integer;

Begin

s := 0;

for k := 14 to 18 do

s := s+7;

writeln(s);

End.


55
Задание 9 № 1262

Запишите зна­че­ние пе­ре­ме­ной s, по­лу­чен­ное в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль

алг

нач

    цел s, k

    s:=0,

    нц для k от 1 до 11

        s:=s+12

    кц

    вывод s

кон

DIM k, s AS INTEGER

s = 0

FOR k = 1 TO 11

s= s+12

NEXT k

PRINT s

END

Var s,k: integer;

Begin

    s:=0;

for k:=1 to 11 do

        s:=s+12;

    write(s);

End.


56
Задание 9 № 4504

Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трех языках программирования.

 


Алгоритмический языкБейсикПаскаль

алг

нач

цел  s, k

s := 0

    нц для k от 6 до 12

        s := s + 5

кц

вывод s

кон

DIM k, s AS INTEGER

s = 0

FOR k = 6 TO 12

    s = s + 5

NEXT k

PRINT s

END

var s,k: integer;

begin

    s := 0;

    for k := 6 to 12 do

        s := s + 5;

    writeln(s);

end.


57
Задание 9 № 4603

Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трех языках программирования.


Алгоритмический языкБейсикПаскаль

алг

нач

    цел s, k

    s := 1

    нц для k от 1 до 5

        s := s * k

    кц

    вывод s

кон

DIM s, k AS INTEGER

s = 1

FOR k = 1 TO 5

    s = s * k

NEXT k

PRINT s

END

var s,k: integer;

begin

    s := 1;

    for k := 1 to 5 do

        s := s * k;

    write(s);

end.


58
Задание 9 № 5055

Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трех языках программирования.


Алгоритмический языкБейсикПаскаль

алг

нач

    цел k, s

    s := 0

    нц для k от 1 до 10

        s := s + 7

    кц

вывод s

кон

DIM k, s AS INTEGER

s = 0

FOR n = 1 TO 10

    s = s + 7

NEXT n

PRINT s

END

var s, n: integer;

begin

    s := 0;

    for n := 1 to 10 do

        s := s + 7;

    write(s);

end.


Аналоги к заданию № 5055: 5364 6183 Все


Пройти тестирование по этим заданиям