информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 9 № 9

Запишите зна­че­ние переменной s, по­лу­чен­ное в ре­зуль­та­те работы сле­ду­ю­щей программы. Текст про­грам­мы приведён на пяти язы­ках программирования.

 

БейсикPython

DIM k, s AS INTEGER

s = 0

FOR k = 3 TO 7

s = s + 6

NEXT k

PRINT s

s = 0

for k in range(3,8):

    s = s + 6

print (s)

ПаскальАлгоритмический язык

var s,k: integer;

begin

   s := 0;

   for k := 3 to 7 do

      s := s + 6;

   writeln(s);

end.

алг

нач

   цел s, k

   s := 0

   нц для k от 3 до 7

      s := s + 6

   кц

вывод s

кон

С++

#include <iostream>

using namespace std;

int main() {

     int s = 0;

     for (int k = 3; k <= 7; k++)

          s += 6;

     cout << s;

     return 0;

}

 

Пояснение.

Цикл «for k := 3 to 7 do» вы­пол­ня­ет­ся пять раз. Каж­дый раз пе­ре­мен­ная s уве­ли­чи­ва­ет­ся на 6. По­сколь­ку изначально s = 0, после вы­пол­не­ния программы по­лу­чим: s = 5 · 6 = 30.

Источник: ГИА по информатике 31.05.2013. Основная волна. Центр, Урал. Вариант 1301.