СДАМ ГИА: РЕШУ ОГЭ
Образовательный портал для подготовки к экзаменам
Информатика
информатика
сайты - меню - вход - новости


Задания
Версия для печати и копирования в MS Word
Задания Д8 № 69

Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на пяти языках программирования.

 

БейсикPython

DIM k, s AS INTEGER

s = 0

FOR k = 3 TO 8

    s = s + 9

NEXT k

PRINT s

s = 0

for k in range(3,9):

    s = s + 9

print (s)

ПаскальАлгоритмический язык

var s,k: integer;

begin

    s := 0;

    for k := 3 to 8 do

        s := s + 9;

    writeln(s);

end.

алг

нач

   цел s, k

   s := 0

   нц для k от 3 до 8

      s := s + 9

   кц

   вывод s

кон

С++

#include <iostream>

using namespace std;

int main() {

     int s = 0;

     for (int k = 3; k <= 8; k++)

          s += 9;

     cout << s;

     return 0;

}

 

Решение.

Цикл «for k := 3 to 8 do» выполняется шесть раз. Каждый раз переменная s увеличивается на 9. Поскольку изначально s = 0, после выполнения программы получим: s = 9 · 6 = 54.

Источник: ГИА по информатике 31.05.2013. Основная волна. Центр, Урал. Вариант 1304.