СДАМ ГИА: РЕШУ ОГЭ
Образовательный портал для подготовки к экзаменам
Информатика
информатика
сайты - меню - вход - новости


Каталог заданий.
Задания 6. Программа с условным оператором. Формат 2020

Пройти тестирование по этим заданиям
Вернуться к каталогу заданий
Версия для печати и копирования в MS Word
1
Задание 6 № 10458

Ниже приведена программа, записанная на пяти языках программирования.

 

БейсикPython

DIM s, t AS INTEGER

INPUT s

INPUT t

IF s > 10 OR t > 10 THEN

    PRINT ‘ДА’

ELSE

    PRINT ‘НЕТ’

ENDIF

s = int(input())

t = int(input())

if s > 10 or t > 10:

    print("ДА")

else:

    print("НЕТ")

ПаскальАлгоритмический язык

var s, t: integer;

begin

    readln(s);

    readln(t);

    if (s > 10) or (t > 10)

        then writeln('ДА')

        else writeln('НЕТ')

end.

алг

нач

цел s, t

ввод s

ввод t

если s > 10 или t > 10

    то вывод "ДА"

    иначе вывод "НЕТ"

все

кон

С++

#include <iostream>

using namespace std;

int main() {

    int s, t;

    cin >> s;

    cin >> t;

    if (s > 10 || t > 10)

        cout << "ДА";

    else

        cout << "НЕТ";

return 0;

}

 

Было проведено 9 запусков программы, при которых в качестве значений переменных s и t вводились следующие пары чисел:

 

(1, 2); (11, 2); (1, 12); (11, 12); (–11, –12); (–11, 12); (–12, 11); (10, 10); (10, 5).

 

Сколько было запусков, при которых программа напечатала «ДА»?


2
Задание 6 № 10459

Ниже при­ве­де­на про­грам­ма, за­пи­сан­ная на пяти язы­ках про­грам­ми­ро­ва­ния.

 

Бей­сикPython

DIM s, t AS INTEGER

INPUT s

INPUT t

IF s > 12 OR t > 12 THEN

    PRINT ‘ДА’

ELSE

    PRINT ‘НЕТ’

ENDIF

s = int(input())

t = int(input())

if s > 12 or t > 12:

    print("ДА")

else:

    print("НЕТ")

Пас­кальАл­го­рит­ми­че­ский язык

var s, t: integer;

begin

    readln(s);

    readln(t);

    if (s > 12) or (t > 12)

        then writeln('ДА')

        else writeln('НЕТ')

end.

алг

нач

цел s, t

ввод s

ввод t

если s > 12 или t > 12

    то вывод "ДА"

    иначе вывод "НЕТ"

все

кон

С++

#include <iostream>

using namespace std;

int main() {

    int s, t;

    cin >> s;

    cin >> t;

    if (s > 12 || t > 12)

        cout << "ДА";

    else

        cout << "НЕТ";

return 0;

}

 

Было про­ве­де­но 9 за­пус­ков про­грам­мы, при ко­то­рых в ка­че­стве зна­че­ний пе­ре­мен­ных s и t вво­ди­лись сле­ду­ю­щие пары чисел:

 

(1, 13); (14, 2); (1, 12); (11, 12); (–14, –14); (–11, 13); (–4, 11); (2, 9); (8, 6).

 

Сколь­ко было за­пус­ков, при ко­то­рых про­грам­ма на­пе­ча­та­ла «ДА»?


3
Задание 6 № 10460

Ниже при­ве­де­на про­грам­ма, за­пи­сан­ная на пяти язы­ках про­грам­ми­ро­ва­ния.

 

Бей­сикPython

DIM s, t AS INTEGER

INPUT s

INPUT t

IF s > 8 OR t > 8 THEN

    PRINT ‘ДА’

ELSE

    PRINT ‘НЕТ’

ENDIF

s = int(input())

t = int(input())

if s > 8 or t > 8:

    print('ДА')

else:

    print('НЕТ')

Пас­кальАл­го­рит­ми­че­ский язык

var s, t: integer;

begin

    readln(s);

    readln(t);

    if (s > 8) or (t > 8)

        then writeln('ДА')

        else writeln('НЕТ')

end.

алг

нач

цел s, t

ввод s

ввод t

если s > 8 или t > 8

    то вывод "ДА"

    иначе вывод "НЕТ"

все

кон

С++

#include <iostream>

using namespace std;

int main() {

    int s, t;

    cin >> s;

    cin >> t;

    if (s > 8 || t > 8)

        cout << "ДА";

    else

        cout << "НЕТ";

return 0;

}

 

Было про­ве­де­но 9 за­пус­ков про­грам­мы, при ко­то­рых в ка­че­стве зна­че­ний пе­ре­мен­ных s и t вво­ди­лись сле­ду­ю­щие пары чисел:

 

(8, 8); (9, 6); (4, 7); (6, 6); (–9, –2); (–5, 9); (–10, 10); (6, 9); (10, 6).

 

Сколь­ко было за­пус­ков, при ко­то­рых про­грам­ма на­пе­ча­та­ла «ДА»?


4
Задание 6 № 10461

Ниже приведена программа, записанная на пяти языках программирования.

 

БейсикPython

DIM s, t AS INTEGER

INPUT s

INPUT t

IF s > 8 OR t > 8 THEN

    PRINT ‘ДА’

ELSE

    PRINT ‘НЕТ’

ENDIF

s = int(input())

t = int(input())

if s > 8 or t > 8:

    print("ДА")

else:

    print("НЕТ")

ПаскальАлгоритмический язык

var s, t: integer;

begin

    readln(s);

    readln(t);

    if (s > 8) or (t > 8)

        then writeln('ДА')

        else writeln('НЕТ')

end.

алг

нач

цел s, t

ввод s

ввод t

если s > 8 или t > 8

    то вывод "ДА"

    иначе вывод "НЕТ"

все

кон

С++

#include <iostream>

using namespace std;

int main() {

    int s, t;

    cin >> s;

    cin >> t;

    if (s > 8 || t > 8)

        cout << "ДА";

    else

        cout << "НЕТ";

return 0;

}

 

Было проведено 9 запусков программы, при которых в качестве значений переменных s и t вводились следующие пары чисел:

 

(8, 8); (9, 6); (4, 7); (6, 6); (–9, –2); (–5, 9); (–10, 10); (6, 9); (10, 6).

 

Сколько было запусков, при которых программа напечатала «НЕТ»?


5
Задание 6 № 10462

Ниже при­ве­де­на про­грам­ма, за­пи­сан­ная на пяти язы­ках про­грам­ми­ро­ва­ния.

 

Бей­сикPython

DIM s, t AS INTEGER

INPUT s

INPUT t

IF s > 9 OR t > 9 THEN

    PRINT ‘ДА’

ELSE

    PRINT ‘НЕТ’

ENDIF

s = int(input())

t = int(input())

if s > 9 or t > 9:

    print("ДА")

else:

    print("НЕТ")

Пас­кальАл­го­рит­ми­че­ский язык

var s, t: integer;

begin

    readln(s);

    readln(t);

    if (s > 9) or (t > 9)

        then writeln('ДА')

        else writeln('НЕТ')

end.

алг

нач

цел s, t

ввод s

ввод t

если s > 9 или t > 9

    то вывод "ДА"

    иначе вывод "НЕТ"

все

кон

С++

#include <iostream>

using namespace std;

int main() {

    int s, t;

    cin >> s;

    cin >> t;

    if (s > 9 || t > 9)

        cout << "ДА";

    else

        cout << "НЕТ";

return 0;

}

 

Было про­ве­де­но 9 за­пус­ков про­грам­мы, при ко­то­рых в ка­че­стве зна­че­ний пе­ре­мен­ных s и t вво­ди­лись сле­ду­ю­щие пары чисел:

 

(9, 9); (9, 10); (8, 5); (11, 6); (–11, 10); (–5, 9); (–10, 10); (4, 5); (8, 6).

 

Сколь­ко было за­пус­ков, при ко­то­рых про­грам­ма на­пе­ча­та­ла «НЕТ»?


Пройти тестирование по этим заданиям