СДАМ ГИА: РЕШУ ОГЭ
Образовательный портал для подготовки к экзаменам
Информатика
информатика
сайты - меню - вход - новости




Варианты заданий
Версия для печати и копирования в MS Word
1
Задание 0 № 5364

Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трех языках программирования.

Алгоритмический язык

алг

нач

   цел  n, m

   m := 50

   нц для n от 1 до 7

         m := m – 7

   кц

   вывод m

кон

Бейсик

m = 50

FOR n = 1 TO 7

  m = m 7

NEXT n

PRINT m

END

Паскаль

var m, n : integer;

begin

   m := 50;

   for n := 1 to 7 do

      m := m 7;

 write(m);

end.


 

 


2
Задание 0 № 6183

Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трех языках программирования.

Алгоритмический язык

алг

нач

   цел s, k

   s := 0

   нц для k от 3 до 8

         s := s + 3 * k

   кц

   вывод s

кон

Бейсик

DIM s, k AS INTEGER

s = 0

FOR k = 3 TO 8

  s = s + 3 * k

NEXT k

PRINT s

END

Паскаль

var s, k : integer;

begin

 s := 0;

 for k := 3 to 8 do

   s := s + 3 * k;

 write(s);

end.