СДАМ ГИА: РЕШУ ОГЭ
Образовательный портал для подготовки к экзаменам
Информатика
информатика
сайты - меню - вход - новости


Задания
Версия для печати и копирования в MS Word
Задание 0 № 6183

Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трех языках программирования.

Алгоритмический язык

алг

нач

   цел s, k

   s := 0

   нц для k от 3 до 8

         s := s + 3 * k

   кц

   вывод s

кон

Бейсик

DIM s, k AS INTEGER

s = 0

FOR k = 3 TO 8

  s = s + 3 * k

NEXT k

PRINT s

END

Паскаль

var s, k : integer;

begin

 s := 0;

 for k := 3 to 8 do

   s := s + 3 * k;

 write(s);

end.


 

Решение.

Это задание ещё не решено, приводим решение прототипа.


Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на пяти языках программирования.

 

БейсикPython

DIM k, s AS INTEGER

s = 0

FOR k = 1 TO 10

    s = s + 7

NEXT k

PRINT s

s = 0

for k in range(1,11):

    s = s + 7

print (s)

ПаскальАлгоритмический язык

var s,k: integer;

begin

    s := 0;

    for k := 1 to 10 do

        s := s + 7;

    writeln(s);

end.

алг

нач

   цел s, k

   s := 0

   нц для k от 1 до 10

      s := s + 7

   кц

   вывод s

кон

С++

#include <iostream>

using namespace std;

int main() {

     int s = 0;

     for (int k = 1; k <= 10; k++)

          s = s + 7;

     cout << s;

     return 0;

}

 



Цикл «for k:=1 to 10 do» вы­пол­ня­ет­ся десять раз. Каж­дый раз пе­ре­мен­ная s уве­ли­чи­ва­ет­ся на 7. По­сколь­ку из­на­чаль­но s = 0, после вы­пол­не­ния про­грам­мы по­лу­чим: s = 10 · 7 = 70.

 

Ответ: 70.


Аналоги к заданию № 5055: 5364 6183 Все

Прототип задания ·