информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 19 № 720

В элек­трон­ную таблицу за­нес­ли данные о ка­ло­рий­но­сти продуктов. Ниже при­ве­де­ны первые пять строк таблицы.

 

 

В столб­це A за­пи­сан продукт; в столб­це B — со­дер­жа­ние в нём жиров; в столб­це C — со­дер­жа­ние белков; в столб­це D — со­дер­жа­ние углеводов и в столб­це Е — ка­ло­рий­ность этого продукта. Всего в элек­трон­ную таблицу были за­не­се­ны данные по 1000 продуктам.

 

Выполните задание

Откройте файл с дан­ной электронной таблицей. На ос­но­ва­нии данных, со­дер­жа­щих­ся в этой таблице, от­веть­те на два вопроса.

1. Сколь­ко про­дук­тов в таб­ли­це со­дер­жат мень­ше 50 г уг­ле­во­дов и мень­ше 50 г белков? За­пи­ши­те число этих про­дук­тов в ячей­ку H2 таблицы.

2. Ка­ко­ва сред­няя ка­ло­рий­ность про­дук­тов с со­дер­жа­ни­ем жиров менее 1 г? Ответ на этот во­прос за­пи­ши­те в ячей­ку H3 таб­ли­цы с точ­но­стью не менее двух зна­ков после запятой.

 

 

task19.xls

Пояснение.

1. В ячей­ку F2 за­пи­шем формулу =ЕСЛИ(И(D2<50;C2<50);1;0), ско­пи­ру­ем формулу во все ячей­ки диапазона F3:F1001. Таким образом, получим столбец F c нулями и единицами. Далее в ячейку H2 за­пи­шем формулу =СУММ(F2:F1001), тем самым получив количество продуктов, содержащих менее 50 г углеводов и менее 50 г белка: 864.

 

2. Для от­ве­та на вто­рой во­прос в ячей­ку K3 за­пи­шем формулу =СУММЕСЛИ(B2:B1001;"<1";E2:E1001), тем самым получим суммарную калорийность всех продуктов с содержанием жиров менее 1 г. Далее по­счи­та­ем ко­ли­че­ство таких продуктов, для этого используем формулу СЧЁТЕСЛИ(B2:B1001;"<1"). Разделив суммарную калорийность на количество продуктов получим среднее:89,45.

 

Воз­мож­ны и дру­гие варианты решения.

Источник: Демонстрационная вер­сия ГИА—2014 по информатике.