СДАМ ГИА: РЕШУ ОГЭ
Образовательный портал для подготовки к экзаменам
Информатика
информатика
сайты - меню - вход - новости


Задания
Версия для печати и копирования в MS Word
Задания Д17 C1 № 720

В электронную таблицу занесли данные о калорийности продуктов. Ниже приведены первые пять строк таблицы.

 

 

В столбце A записан продукт; в столбце B — содержание в нём жиров; в столбце C — содержание белков; в столбце D — содержание углеводов и в столбце Е — калорийность этого продукта. Всего в электронную таблицу были занесены данные по 1000 продуктам.

 

Выполните задание

Откройте файл с данной электронной таблицей. На основании данных, содержащихся в этой таблице, ответьте на два вопроса.

1. Сколько продуктов в таблице содержат меньше 50 г углеводов и меньше 50 г белков? Запишите число этих продуктов в ячейку H2 таблицы.

2. Какова средняя калорийность продуктов с содержанием жиров менее 1 г? Ответ на этот вопрос запишите в ячейку H3 таблицы с точностью не менее двух знаков после запятой.

 

 

task19.xls

Решение.

1. В ячейку F2 запишем формулу =ЕСЛИ(И(D2<50;C2<50);1;0), скопируем формулу во все ячейки диапазона F3:F1001. Таким образом, получим столбец F c нулями и единицами. Далее в ячейку H2 запишем формулу =СУММ(F2:F1001), тем самым получив количество продуктов, содержащих менее 50 г углеводов и менее 50 г белка: 864.

 

2. Для ответа на второй вопрос в ячейку K3 запишем формулу =СУММЕСЛИ(B2:B1001;"<1";E2:E1001), тем самым получим суммарную калорийность всех продуктов с содержанием жиров менее 1 г. Далее посчитаем количество таких продуктов, для этого используем формулу СЧЁТЕСЛИ(B2:B1001;"<1"). Разделив суммарную калорийность на количество продуктов получим среднее:89,45.

 

Возможны и другие варианты решения.

Источник: Демонстрационная вер­сия ГИА—2014 по информатике.