СДАМ ГИА: РЕШУ ОГЭ
Образовательный портал для подготовки к экзаменам
Информатика
информатика
сайты - меню - вход - новости


Задания
Версия для печати и копирования в MS Word
Задания Д9 № 710

Запишите зна­че­ние переменной s, по­лу­чен­ное в ре­зуль­та­те работы сле­ду­ю­щей программы. Текст про­грам­мы приведён на пяти язы­ках программирования.

 

БейсикPython

DIM k, s AS INTEGER

s = 0

FOR k = 6 TO 12

    s = s + 10

NEXT k

PRINT s

s = 0

for k in range(6,13):

    s = s + 10

print (s)

ПаскальАлгоритмический язык

var s,k: integer;

begin

    s := 0;

    for k := 6 to 12 do

        s := s + 10;

    writeln(s);

end.

алг

нач

   цел s, k

   s := 0

   нц для k от 6 до 12

      s := s + 10

   кц

   вывод s

кон

С++

#include <iostream>

using namespace std;

int main() {

     int s = 0;

     for (int k = 6; k <= 12; k++)

          s = s + 10;

     cout << s;

     return 0;

}

 

Решение.

Цикл «for k := 6 to 12 do» вы­пол­ня­ет­ся семь раз. Каж­дый раз пе­ре­мен­ная s уве­ли­чи­ва­ет­ся на 10. По­сколь­ку изначально s = 0, после вы­пол­не­ния программы по­лу­чим: s = 7 · 10 = 70.

 

Ответ: 70.

Источник: Демонстрационная вер­сия ГИА—2014 по информатике.