СДАМ ГИА: РЕШУ ОГЭ
Образовательный портал для подготовки к экзаменам
Информатика
информатика
сайты - меню - вход - новости


Задания
Версия для печати и копирования в MS Word
Задание 0 № 5867

Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трех языках программирования.

Алгоритмический язык

Бейсик

Паскаль

алг

нач

цел  s, k

s := 0

 нц для k от 4 до 8

  s := s + 13

кц

вывод s

кон

DIM k, s AS INTEGER

s = 0

FOR k = 4 TO 8

  s = s + 13

NEXT k

PRINT s

END

var s,k: integer;

begin

 s := 0;

 for k := 4 to 8 do

   s := s + 13;

 writeln(s);

end.

 


 

Решение.

Это задание ещё не решено, приводим решение прототипа.


Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на пяти языках программирования.

 

БейсикPython

DIM k, s AS INTEGER

s = 0

FOR k = 6 TO 12

    s = s + 5

NEXT k

PRINT s

s = 0

for k in range(6,13):

    s = s + 5

print (s)

ПаскальАлгоритмический язык

var s,k: integer;

begin

    s := 0;

    for k := 6 to 12 do

        s := s + 5;

    writeln(s);

end.

алг

нач

   цел s, k

   s := 0

   нц для k от 6 до 12

      s := s + 5

   кц

   вывод s

кон

С++

#include <iostream>

using namespace std;

int main() {

     int s = 0;

     for (int k = 6; k <= 12; k++)

          s = s + 5;

     cout << s;

     return 0;

}

 



Цикл «for k := 6 to 12 do» вы­пол­ня­ет­ся семь раз. Каж­дый раз пе­ре­мен­ная s уве­ли­чи­ва­ет­ся на 5. По­сколь­ку из­на­чаль­но s = 0, после вы­пол­не­ния про­грам­мы по­лу­чим: s = 7 · 5 = 35.

 

Ответ: 35.

Прототип задания ·