СДАМ ГИА: РЕШУ ОГЭ
Образовательный портал для подготовки к экзаменам
Информатика
информатика
сайты - меню - вход - новости


Задания
Версия для печати и копирования в MS Word
Задания Д17 C1 № 139

В электронную таблицу занесли данные о тестировании учеников. Ниже приведены первые пять строк таблицы:

 

ABCD
1округфамилияпредметбалл
2CУченик 1обществознание246
3ВУченик 2немецкий язык530
4ЮУченик 3русский язык576
5СВУченик 4обществознание304

 

В столбце А записан округ, в котором учится ученик; в столбце В — фамилия; в столбце С — любимый предмет; в столбце D — тестовый балл. Всего в электронную таблицу были занесены данные по 1000 ученикам.

 

Выполните задание.

Откройте файл с данной электронной таблицей (расположение файла Вам сообщат организаторы экзамена). На основании данных, содержащихся в этой таблице, ответьте на два вопроса.

1. Сколько учеников в Юго-Западном округе (ЮЗ) выбрали в качестве любимого предмета обществознание? Ответ на этот вопрос запишите в ячейку Н2 таблицы.

2. Каков средний тестовый балл у учеников Центрального округа (Ц)? Ответ на этот вопрос запишите в ячейку Н3 таблицы с точностью не менее двух знаков после запятой.

 

 

task19.xls

Решение.

task19.xls

 

1. Запишем в ячейку H2 следующую формулу =ЕСЛИ(A2="ЮЗ";C2;0) и скопируем ее в диапазон H3:H1001. В таком случае, в ячейку столбца Н будет записываться название предмета, если ученик из Юго-Западного округа и «0», если это не так. Применив операцию =ЕСЛИ(H2="обществознание";1;0), получим столбец(J) с единицами и нулями. Далее, используем операцию =СУММ(J2:J1001). Получим количество учеников, которые считают своим любимым предметом обществознание. Таких 30 человек.

2. Для ответа на второй вопрос используем операцию «ЕСЛИ». Запишем в ячейку E2 следующее выражение: =ЕСЛИ(A2="Ц";D2;0), в результате применения данной операции к диапазону ячеек Е2:Е1001, получим столбец, в котором записаны баллы только учеников из Центрального округа. Сложим значения в ячейках, получим сумму баллов учеников: 55 254. Найдём количество учеников из Центрального округа с помощью команды =СЧЁТЕСЛИ(A2:A1001;"Ц"), получим 103. Разделив сумму баллов на количество учеников, получим: 536,45 — искомый средний балл.

 

Ответ: 1) 30; 2) 536,45.

Источник: ГИА по информатике 31.05.2013. Основная волна. Сибирь, Дальний Восток. Вариант 1307.