информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 19 № 1050

На ме­тео­стан­ции дан­ные о по­го­де за­нес­ли в элек­трон­ную таблицу. Ниже при­ве­де­ны пер­вые пять строк таблицы, в ко­то­рую были за­не­се­ны дан­ные о по­го­де в пе­ри­од с ян­ва­ря 2013 года по ян­варь 2014 года.

 

ABCDE
1ДатаТемпература, оСАтм. давление, мм рт. ст.Скорость ветра, м/сОблачность, %
201.01.2013–0,37461100
302.01.20130,57461100
403.01.2013–27441100
504.01.20130,87401100
605.01.2013–0,87411100

 

Каждая стро­ка таб­ли­цы со­дер­жит за­пись о по­го­де од­но­го дня. В столб­це A за­пи­са­на дата; в столб­це B – тем­пе­ра­ту­ра воздуха; в столб­це C — ат­мо­сфер­ное давление; в столб­це D — ско­рость ветра; в столб­це E — облачность. Всего в элек­трон­ную таб­ли­цу были за­не­се­ны дан­ные о по­го­де за 396 дней.

 

 

task19.xls

 

Выполните задание.

Откройте файл с дан­ной элек­трон­ной таб­ли­цей. На ос­но­ва­нии данных, со­дер­жа­щих­ся в этой таблице, от­веть­те на два вопроса.

 

1. Сколь­ко дней за приведённый период тем­пе­ра­ту­ра была ниже –10 оС? Ответ на этот во­прос за­пи­ши­те в ячей­ку Н2 таблицы.

2. Ка­ко­ва сред­няя ско­рость ветра в дни с об­лач­но­стью менее 80%? Ответ на этот во­прос с точ­но­стью не менее двух зна­ков после за­пя­той за­пи­ши­те в ячей­ку H3 таблицы.

Пояснение.

Решение для OpenOffice.org Calc и для Microsoft Excel

 

Первая фор­му­ла ис­поль­зу­ет­ся для рус­ско­языч­ной за­пи­си функций, вто­рая — для англоязычной.

В ячей­ку H2 за­пи­шем формулу, определяющую, сколь­ко дней за дан­ный пе­ри­од было с тем­пе­ра­ту­рой ниже –10 оС:

 

=СЧЁТЕСЛИ(B2:B397;"<–10")

=COUNTIF(B2:B397;"<–10")

 

Для от­ве­та на вто­рой во­прос в столб­це G для каж­до­го дня за­пи­шем ско­рость ветра, если в этот день об­лач­ность менее 80%, и 0 в об­рат­ном случае. В ячей­ку G2 за­пи­шем формулу

 

=ЕСЛИ(E2<80;D2;" ")

=IF(E2<80;D2;" ")

 

Скопируем фор­му­лу во все ячей­ки диа­па­зо­на G2:G397. Далее, чтобы опре­де­лить сред­нюю ско­рость ветра, за­пи­шем фор­му­лу в ячей­ку H3:

 

=СРЗНАЧ(G2:G397)

=AVERAGE(G2:G397)

 

Возможны и дру­гие ва­ри­ан­ты решения.

Если за­да­ние вы­пол­не­но пра­виль­но и при вы­пол­не­нии за­да­ния ис­поль­зо­ва­лись файлы, спе­ци­аль­но под­го­тов­лен­ные для про­вер­ки вы­пол­не­ния дан­но­го задания, то долж­ны по­лу­чить­ся сле­ду­ю­щие ответы: на пер­вый вопрос: 32; на вто­рой вопрос: 1,57.