№№ заданий Пояснения Ответы Ключ Добавить инструкцию Критерии
Источник Раздел кодификатора ФИ­ПИ
PDF-версия PDF-версия (вертикальная) PDF-версия (крупный шрифт) PDF-версия (с большим полем) Версия для копирования в MS Word
Задания
Задания Д17 C1 № 1050

На метеостанции данные о погоде занесли в электронную таблицу. Ниже приведены первые пять строк таблицы, в которую были занесены данные о погоде в период с января 2013 года по январь 2014 года.

 

ABCDE
1ДатаТемпература, оСАтм. давление, мм рт. ст.Скорость ветра, м/сОблачность, %
201.01.2013–0,37461100
302.01.20130,57461100
403.01.2013–27441100
504.01.20130,87401100
605.01.2013–0,87411100

 

Каждая строка таблицы содержит запись о погоде одного дня. В столбце A записана дата; в столбце B – температура воздуха; в столбце C — атмосферное давление; в столбце D — скорость ветра; в столбце E — облачность. Всего в электронную таблицу были занесены данные о погоде за 396 дней.

 

 

task19.xls

 

Выполните задание.

Откройте файл с данной электронной таблицей. На основании данных, содержащихся в этой таблице, ответьте на два вопроса.

 

1. Сколько дней за приведённый период температура была ниже –10 оС? Ответ на этот вопрос запишите в ячейку Н2 таблицы.

2. Какова средняя скорость ветра в дни с облачностью менее 80%? Ответ на этот вопрос с точностью не менее двух знаков после запятой запишите в ячейку H3 таблицы.

Решение.

Решение для OpenOffice.org Calc и для Microsoft Excel

 

Первая формула используется для русскоязычной записи функций, вторая — для англоязычной.

В ячейку H2 запишем формулу, определяющую, сколько дней за данный период было с температурой ниже –10 оС:

 

=СЧЁТЕСЛИ(B2:B397;"<–10")

=COUNTIF(B2:B397;"<–10")

 

Для ответа на второй вопрос в столбце G для каждого дня запишем скорость ветра, если в этот день облачность менее 80%, и 0 в обратном случае. В ячейку G2 запишем формулу

 

=ЕСЛИ(E2<80;D2;" ")

=IF(E2<80;D2;" ")

 

Скопируем формулу во все ячейки диапазона G2:G397. Далее, чтобы определить среднюю скорость ветра, запишем формулу в ячейку H3:

 

=СРЗНАЧ(G2:G397)

=AVERAGE(G2:G397)

 

Можно использовать формулу =СРЗНАЧЕСЛИ(E2:E397;"<80";D2:D397). Тогда предыдущие два действия не требуются.

 

Возможны и другие варианты решения.

Если задание выполнено правильно и при выполнении задания использовались файлы, специально подготовленные для проверки выполнения данного задания, то должны получиться следующие ответы: на первый вопрос: 32; на второй вопрос: 1,57.