информатика
сайты - меню - вход - новости




Варианты заданий
Версия для печати и копирования в MS Word
1
Задание 0 № 4712

В таблице Ball хранятся баллы, набранные участниками школьного тура олимпиады по математике (Ball[1] − балл 1 ученика, Ball[2] − балл 2 ученика и т.д.). Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трёх языках программирования.

 

Алгоритмический язык

    алг

    нач

        целтаб Ball[1:10]

        цел k, m

        Ball[1] := 42; Ball[2] := 25

        Ball[3] := 13; Ball[4] := 18

        Ball[5] := 15; Ball[6] := 55

        Ball[7] := 48; Ball[8] := 13

        Ball[9] := 64; Ball[10] := 45

        m := Ball[1]

        нц для k от 1 до 10

             если Ball[k] > m то

                  m := Ball[k]

             все

        кц

        вывод m

кон

Бейсик

Паскаль

DIM Ball(10) AS INTEGER

DIM k, m AS INTEGER

Ball(1) = 42: Ball(2) = 25

Ball(3) = 13: Ball(4) = 18

Ball(5) = 15: Ball(6) = 55

Ball(7) = 48: Ball(8) = 13

Ball(9) = 64: Ball(10) = 45

m = Ball(1)

FOR k = 1 TO 10

 IF Ball(k) > m THEN

  m = Ball(k)

 END IF

NEXT k

PRINT m

END

var k, m, t: integer;

Ball: array[1..10] of integer;

begin

 Ball[1] := 42; Ball[2] := 25;

 Ball[3] := 13; Ball[4] := 18;

 Ball[5] := 15; Ball[6] := 55;

 Ball[7] := 48; Ball[8] := 13;

 Ball[9] := 64; Ball[10] := 45;

 m := Ball[1];

 for k := 1 to 10 do

  if Ball[k] > m then

   m := Ball[k];

 write(m);

end.


 

 


2
Задание 0 № 4846

В таблице Ball хранятся отметки по контрольной работе (Ball[1] − отметка 1 ученика, Ball[2] − отметка 2 ученика и т.д.). Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трёх языках программирования.

 

Алгоритмический язык

алг

нач

  целтаб Ball[1:10]

  цел k, c

  Ball[1] := 3; Ball[2] := 5

  Ball[3] := 3; Ball[4] := 2

  Ball[5] := 5; Ball[6] := 5

  Ball[7] := 4; Ball[8] := 3

  Ball[9] := 3; Ball[10] := 5

  c := 0

  нц для k от 1 до 10

    если Ball[k] < 4 то

      c := c + 1

    все

  кц

  вывод c

кон

Бейсик

Паскаль

DIM Ball(10) AS INTEGER

DIM k, c AS INTEGER

Ball(1) = 3: Ball(2) = 5

Ball(3) = 3: Ball(4) = 2

Ball(5) = 5: Ball(6) = 5

Ball(7) = 4: Ball(8) = 3

Ball(9) = 3: Ball(10) = 5

c = 0

FOR k = 1 TO 10

 IF Ball(k)< 4 THEN

  c = c + 1

 END IF

NEXT k

PRINT c

END

var k, c: integer;

Ball: array[1..10] of integer;

begin

  Ball[1] := 3; Ball[2] := 5;

  Ball[3] := 3; Ball[4] := 2;

  Ball[5] := 5; Ball[6] := 5;

  Ball[7] := 4; Ball[8] := 3;

  Ball[9] := 3; Ball[10] := 5;

  c := 0;

  for k := 1 to 10 do

    if Ball[k] < 4 then

      c := c + 1;

  write(c);

end.


 


3
Задание 0 № 4904

В таблице Ball хранятся баллы, набранные участниками школьного тура олимпиады по математике (Ball[1] − балл 1 ученика, Ball[2] − балл 2 ученика и т.д.). Определите, что будет напечатано в результате работы следующей программы. Текст программы приведен на трёх языках программирования.

 

Алгоритмический язык

алг

нач

    целтаб Ball[1:10]

    цел k, m, t

    Ball[1]:=12; Ball[2]:=25

    Ball[3]:=13; Ball[4]:=18

    Ball[5]:=35; Ball[6]:=55

    Ball[7]:=48; Ball[8]:=33

    Ball[9]:=64; Ball[10]:=45

    m := Ball[1]; t := 1

    нц для k от 1 до 10

         если Ball[k] > m то

               m := Ball[k]

               t := k

         все

    кц

    вывод t

кон

Бейсик

Паскаль

DIM Ball(10) AS INTEGER

DIM k, m, t AS INTEGER

Ball(1)=12: Ball(2)=25

Ball(3)=13: Ball(4)=18

Ball(5)=35: Ball(6)=55

Ball(7)=48: Ball(8)=33

Ball(9)=64: Ball(10)=45

m = Ball(1): t = 1

FOR k = 1 TO 10

    IF Ball(k) > m THEN

         m = Ball(k)

         t = k

    END IF

NEXT k

PRINT t

END

var k, m, t: integer;

Ball: array[1..10] of integer;

begin

 Ball[1]:=12; Ball[2]:=25;

 Ball[3]:=13; Ball[4]:=18;

 Ball[5]:=35; Ball[6]:=55;

 Ball[7]:=48; Ball[8]:=33;

 Ball[9]:=64; Ball[10]:=45;

 m := Ball[1]; t := 1;

 for k := 1 to 10 do

  if Ball[k] > m then

   begin

    m := Ball[k];

    t := k

   end;

 write(t);

end.


 

 


4
Задание 0 № 5639

В таблице Ball хранятся отметки по контрольной работе (Ball[1] − отметка 1 ученика, Ball[2] − отметка 2 ученика и т.д.). Определите, что будет напечатано в результате работы следующего алгоритма, записанного на трёх языках программирования.

 

Алгоритмический язык

алг

нач

  целтаб Ball[1:10]

  цел k, c

  Ball[1] := 4; Ball[2] := 5

  Ball[3] := 3; Ball[4] := 4

  Ball[5] := 2; Ball[6] := 5

  Ball[7] := 4; Ball[8] := 3

  Ball[9] := 4; Ball[10] := 5

  c:= 0

  нц для k от 1 до 10

    если Ball[k] > 3 то

      c := c + 1

    все

  кц

  вывод c

кон

Бейсик

Паскаль

DIM Ball(10) AS INTEGER

DIM k, c AS INTEGER

Ball(1) = 4: Ball(2) = 5

Ball(3) = 3: Ball(4) = 4

Ball(5) = 2: Ball(6) = 5

Ball(7) = 4: Ball(8) = 3

Ball(9) = 4: Ball(10) = 5

c = 0

FOR k = 1 TO 10

 IF Ball(k) > 3 THEN

  c = c + 1

 END IF

NEXT k

PRINT c

END

var k, c: integer;

Ball: array[1..10] of integer;

begin

  c:=0;

  Ball[1] := 4; Ball[2] := 5;

  Ball[3] := 3; Ball[4] := 4;

  Ball[5] := 2; Ball[6] := 5;

  Ball[7] := 4; Ball[8] := 3;

  Ball[9] := 4; Ball[10] := 5;

  for k := 1 to 10 do

    if Ball[k] > 3 then

      c := c + 1;

  write(c);

end.