информатика
Математика
Информатика
Английский язык
Немецкий язык
Французcкий язык
Испанский язык
Физика
Химия
Биология
География
Обществознание
Литература
История
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 9 № 972

Запишите зна­че­ние пе­ре­мен­ной s, по­лу­чен­ное в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль

алг

нач

цел s, k

s := 0

нц для k от 6 до 12

s := s+10

кц

вывод s

кон

DIM k, s AS INTEGER

s = 0

FOR k = 6 TO 12

s = s+10

NEXT k

PRINT s

Var s,k: integer;

Begin

s := 0;

for k := 6 to 12 do

s := s+10;

writeln(s);

End.

Пояснение.

Цикл for k := 6 to 12 do вы­пол­нит­ся 7 раз. Каж­дый раз пе­ре­мен­ная s уве­ли­чи­ва­ет­ся на 10. По­сколь­ку из­на­чаль­но зна­че­ние s равно 0, после вы­пол­не­ния про­грам­мы по­лу­чим s = 70.

 

Ответ: 70.

Источник: Де­мон­стра­ци­он­ная вер­сия ОГЭ—2018 по информатике., Демонстрационная вер­сия ГИА—2015.