СДАМ ГИА: РЕШУ ОГЭ
Образовательный портал для подготовки к экзаменам
Информатика
информатика
сайты - меню - вход - новости


Задания
Версия для печати и копирования в MS Word
Задание 15 № 963

15.1

На бесконечном поле имеется вертикальная стена. Длина стены неизвестна. От верхнего конца стены вправо отходит горизонтальная стена также неизвестной длины. Робот находится в клетке, расположенной слева от нижнего края вертикальной стены.

На рисунке указан один из возможных способов расположения стен и Робота (Робот обозначен буквой «Р»).

Напишите для Робота алгоритм, закрашивающий все клетки, расположенные левее вертикальной стены и выше горизонтальной стены и прилегающие к ним. Робот должен закрасить только клетки, удовлетворяющие данному условию. Например, для приведённого выше рисунка Робот должен закрасить следующие клетки (см. рисунок).

Конечное расположение Робота может быть произвольным. Алгоритм должен решать задачу для произвольного размера поля и любого допустимого расположения стен внутри прямоугольного поля. При исполнении алгоритма Робот не должен разрушиться. Алгоритм напишите в текстовом редакторе и сохраните в текстовом файле. Название файла и каталог для сохранения Вам сообщат организаторы экзамена.

 

15.2 Напишите программу, которая в последовательности целых чисел определяет количество чётных чисел, кратных 7. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000. Программа должна вывести одно число: количество чётных чисел, кратных 7.

 

Пример работы программы:

 

Входные данныеВыходные данные

–32

14

17

0

1

Решение.

15.1 Команды исполнителя будем записывать жирным шрифтом, а комментарии, поясняющие алгоритм и не являющиеся его частью, — курсивом. Начало комментария будем обозначать символом «|».

 

| Двигаемся вверх, пока не дойдём до конца вертикальной стены, закрашивая все клетки на пути

нц пока не справа свободно

закрасить

вверх

кц

 

| Закрасим угловую клетку и переместимся в начало горизонтальной стены

закрасить

вправо

 

| Двигаемся вправо до конца горизонтальной стены, закрашивая все клетки на пути

нц пока не снизу свободно

закрасить

вправо

кц

 

Возможны и другие варианты решения.

 

15.2 Вариант решения на языке Паскаль.

var a, answer: integer;

begin

answer:=0;

readln(a);

while a<>0 do begin

if (a mod 2 = 0) and (a mod 7 = 0) then

answer := answer + 1;

readln(a); end;

writeln(answer);

end.