информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 19 № 958

На ме­тео­стан­ции дан­ные о по­го­де за­нес­ли в элек­трон­ную таблицу. Ниже при­ве­де­ны пер­вые пять строк таблицы, в ко­то­рую были за­не­се­ны дан­ные о по­го­де в пе­ри­од с ян­ва­ря 2013 года по ян­варь 2014 года.

 

 

Каждая стро­ка таб­ли­цы со­дер­жит за­пись о по­го­де од­но­го дня. В столб­це A за­пи­са­на дата; в столб­це B — температура воздуха; в столб­це C — ат­мо­сфер­ное давление; в столб­це D – ско­рость ветра; в столб­це E – облачность. Всего в элек­трон­ную таб­ли­цу были за­не­се­ны дан­ные о по­го­де за 396 дней.

 

 

task19.xls

 

Выполните задание.

Откройте файл с дан­ной элек­трон­ной таб­ли­цей. На ос­но­ва­нии данных, со­дер­жа­щих­ся в этой таблице, от­веть­те на два вопроса.

 

1. Сколь­ко дней за дан­ный период ат­мо­сфер­ное давление было ниже 760 мм ртут­но­го столба? Ответ на этот во­прос запишите в ячей­ку H2 таблицы.

2. Какое сред­нее атмосферное дав­ле­ние было в дни с тем­пе­ра­ту­рой воздуха ниже 0 °C? Ответ на этот во­прос с точ­но­стью не менее 2 зна­ков после за­пя­той запишите в ячей­ку H3 таблицы.

Пояснение.

Решение для OpenOffice.org Calc и для Microsoft Excel

 

Первая фор­му­ла ис­поль­зу­ет­ся для рус­ско­языч­ной за­пи­си функций, вто­рая — для англоязычной.

 

В ячей­ку H2 за­пи­шем формулу, определяющую, сколь­ко дней за дан­ный период ат­мо­сфер­ное давление было ниже 760 мм ртут­но­го столба:

 

=СЧЁТЕСЛИ(C2:C397;"<760")

=COUNTIF(C2:C397;"<760")

 

Для от­ве­та на вто­рой вопрос в ячейке, в столб­це G для каж­до­го дня за­пи­шем атмосферное давление, если в этот день тем­пе­ра­ту­ра воздуха ниже 0 °С, и "" в об­рат­ном случае. В ячей­ку G2 за­пи­шем формулу

 

=ЕСЛИ(B2<0;C2;"")

=IF(B2<0;C2; "")

 

Скопируем фор­му­лу во все ячей­ки диапазона G2:G397. Далее, чтобы опре­де­лить среднюю ско­рость ветра,

запишем фор­му­лу в ячей­ку H3:

 

=СРЗНАЧ(G2:G397)

=AVERAGE(G2:G397)

 

Возможны и дру­гие спо­со­бы ре­ше­ния задачи.

 

Если за­да­ние вы­пол­не­но пра­виль­но и при вы­пол­не­нии за­да­ния ис­поль­зо­ва­лись файлы, спе­ци­аль­но под­го­тов­лен­ные для про­вер­ки вы­пол­не­ния дан­но­го задания, то долж­ны по­лу­чить­ся сле­ду­ю­щие ответы:

на пер­вый вопрос: 383;

на вто­рой вопрос: 748,96.