СДАМ ГИА: РЕШУ ОГЭ
Образовательный портал для подготовки к экзаменам
Информатика
информатика
сайты - меню - вход - новости


Задания
Версия для печати и копирования в MS Word
Задания Д8 № 948

Запишите значение переменной t, полученное в результате работы следующей программы. Текст программы приведён на пяти языках программирования.

 

БейсикPython

DIM t, i AS INTEGER

t = 2

FOR i = 1 TO 3

    t = t * i

NEXT i

PRINT t

t = 2

for i in range(1,4):

    t = t * i

print (t)

ПаскальАлгоритмический язык

var t, i: integer;

begin

    t := 2;

    for i := 1 to 3 do

        t := t * i;

    writeln(t);

end.

алг

нач

   цел t, i

   t := 2;

   нц для i от 1 до 3

      t := t * i

   кц

   вывод t

кон

С++

#include <iostream>

using namespace std;

int main() {

    int t = 2;

    for (int i = 1; i <= 3; i++)

         t = t * i;

    cout << t;

    return 0;

}

 

Решение.

Цикл for i := 1 to 3 do выполняется 3 раза. Каждый раз переменная t умножается на i. поскольку изначально значение t равно 2, после выполнения программы получим t = 2 · 1 · 2 · 3=12.

 

Ответ: 12.