СДАМ ГИА: РЕШУ ОГЭ
Образовательный портал для подготовки к экзаменам
Информатика
информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 9 № 928

Запишите зна­че­ние пе­ре­мен­ной t, по­лу­чен­ное в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей программы. Текст про­грам­мы приведён на пяти язы­ках программирования.

 

БейсикPython

DIM t, i AS INTEGER

t = 1

FOR i = 1 TO 4

    t = t * i

NEXT i

PRINT t

t = 1

for i in range(1,5):

    t = t * i

print (t)

ПаскальАлгоритмический язык

var t, i: integer;

begin

    t := 1;

    for i := 1 to 4 do

        t := t * i;

    writeln(t);

end.

алг

нач

   цел t, i

   t := 1;

   нц для i от 1 до 4

      t := t * i

   кц

   вывод t

кон

С++

#include <iostream>

using namespace std;

int main() {

    int t = 1;

    for (int i = 1; i <= 4; i++)

         t = t * i;

    cout << t;

    return 0;

}

 

Пояснение.

Цикл for i := 1 to 4 do вы­пол­ня­ет­ся 4 раза. Каж­дый раз пе­ре­мен­ная t умножается на i. по­сколь­ку из­на­чаль­но зна­че­ние t равно 1, после вы­пол­не­ния про­грам­мы по­лу­чим t = 1 · 1 · 2 · 3 · 4 = 24.

 

Ответ: 24.