СДАМ ГИА: РЕШУ ОГЭ
Образовательный портал для подготовки к экзаменам
Информатика
информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 19 № 918

В из­да­тель­стве дет­ских книг дан­ные об из­дан­ных кни­гах хра­нят­ся в элек­трон­ной таблице. Ниже при­ве­де­ны пер­вые пять строк таблицы.

 

ABCD
1АвторНазвание книгиГод создания произведенияРейтинг книги
2Агния БартоСтихи для детей1925316
3Алан Александр МилнВинни-Пух1928254
4Александр ВолковВолшебник Изумрудного города19391235
5Александр ПушкинРуслан и Людмила18201472
6Александр ПушкинСказка о царе Салтане1831900

 

Каждая стро­ка таб­ли­цы со­дер­жит за­пись об одной книге. В столб­це A за­пи­сан автор книги; в столб­це B — название книги; в столб­це C — год со­зда­ния произведения; в столб­це D — рейтинг книги. Всего в элек­трон­ную таб­ли­цу были за­не­се­ны дан­ные по 134 кни­гам в про­из­воль­ном порядке.

 

 

task19.xls

 

Выполните задание.

Откройте файл с дан­ной элек­трон­ной таблицей. На ос­но­ва­нии данных, со­дер­жа­щих­ся в этой таблице, от­веть­те на два вопроса.

 

1. Какое ко­ли­че­ство про­из­ве­де­ний со­зда­но до 1910 года? Ответ на этот во­прос за­пи­ши­те в ячей­ку E2 таблицы.

2. Какой про­цент книг, на­пи­сан­ных позже 1950 года, имеют рей­тинг выше 500? Ответ на этот во­прос с точ­но­стью не менее 2 зна­ков после за­пя­той за­пи­ши­те в ячей­ку E3 таблицы.

Пояснение.

Решение для OpenOffice.org Calc и для Microsoft Excel

 

Первая фор­му­ла ис­поль­зу­ет­ся для рус­ско­языч­ной за­пи­си функций, вто­рая — для англоязычной.

 

Для от­ве­та на пер­вый во­прос в ячей­ку E2 за­пи­шем формулу

=СЧЁТЕСЛИ(C2:C135;"<1910")

=COUNTIF(C2:C135;" <1910")

 

Для от­ве­та на вто­рой во­прос в столб­це F для каж­дой книги за­пи­шем её рейтинг, если её из­да­ли позже 1950 года и 0 в об­рат­ном случае. В ячей­ку F2 за­пи­шем формулу

 

=ЕСЛИ(C2>1950;D2;0)

=IF(C2>1950;D2;0)

 

Скопируем фор­му­лу во все ячей­ки диа­па­зо­на F2:F135. Далее, чтобы опре­де­лить книги, рей­тинг ко­то­рых боль­ше 500, за­пи­шем в ячей­ку G2 формулу

 

=СЧЁТЕСЛИ(F2:F135;">500")

=COUNTIF(F2:F135;" >500")

 

Сосчитаем ко­ли­че­ство книг, из­дан­ных позже 1950 года. В ячей­ку G3 за­пи­шем формулу

 

=СЧЁТЕСЛИ(C2:C135;">1950")

=COUNTIF(C2:C135;">1950")

 

Для по­лу­че­ния окон­ча­тель­но­го от­ве­та за­пи­шем в ячей­ку E3 формулу

 

=G2*100/G3

 

Возможны и дру­гие спо­со­бы ре­ше­ния задачи.

 

Если за­да­ние вы­пол­не­но пра­виль­но и ис­поль­зо­ва­лись файлы, спе­ци­аль­но под­го­тов­лен­ные для про­вер­ки вы­пол­не­ния дан­но­го задания, то долж­ны по­лу­чить­ся сле­ду­ю­щие ответы:

на пер­вый во­прос — 31;

на вто­рой во­прос — 82,81.