информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 9 № 908

Запишите значение переменной d, полученное в результате работы следующей программы. Текст программы приведён на пяти языках программирования.

 

БейсикPython

DIM d, n, i AS INTEGER

n = 3

d = n*3

FOR i = 1 TO 3

    d = d + i

NEXT i

PRINT d

n = 3

d = n*3

for i in range(1,4):

    d = d + i

print (d)

ПаскальАлгоритмический язык

var d, n, i: integer;

begin

    n := 3;

    d := n*3;

    for i := 1 to 3 do

        d := d + i;

    writeln(d);

end.

алг

нач

   цел d, n, i

   n := 3

   d := n*3

   нц для i от 1 до 3

      d := d + i

   кц

   вывод d

кон

С++

#include <iostream>

using namespace std;

int main() {

     int n = 3;

     int d = n*3;

     for (int i = 1; i <= 3; i++)

          d = d + i;

     cout << d;

     return 0;

}

 

Пояснение.

Цикл for i := 1 to 3 do выполняется 3 раза. Каждый раз переменная d увеличивается на i. поскольку изначально значение d равно 9, после выполнения программы получим d = 9 + 1 + 2 + 3 = 15.

 

Ответ: 15.