СДАМ ГИА: РЕШУ ОГЭ
Образовательный портал для подготовки к экзаменам
Информатика
информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 9 № 888

Запишите зна­че­ние пе­ре­мен­ной d, по­лу­чен­ное в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей программы. Текст про­грам­мы приведён на пяти язы­ках программирования.

 

БейсикPython

DIM d, n, i AS INTEGER

n = 4

d = n*2

FOR i = 1 TO 3

    d = d + 2*i

NEXT i

PRINT d

n = 4

d = n*2

for i in range(1,4):

    d = d + 2*i

print (d)

ПаскальАлгоритмический язык

var d, n, i: integer;

begin

    n := 4;

    d := n*2;

    for i := 1 to 3 do

        d := d + 2*i;

    writeln(d);

end.

алг

нач

   цел d, n, i

   n := 4

   d := n*2

   нц для i от 1 до 3

      d := d + 2*i

   кц

   вывод d

кон

С++

#include <iostream>

using namespace std;

int main() {

     int n = 4;

     int d = n*2;

     for (int i = 1; i <= 3; i++)

          d = d + 2*i;

     cout << d;

     return 0;

}

 

Пояснение.

Цикл for i := 1 to 3 do вы­пол­ня­ет­ся 3 раза. Каж­дый раз пе­ре­мен­ная d увеличивается на 2*i. по­сколь­ку изначально зна­че­ние d равно 8, после вы­пол­не­ния программы по­лу­чим d = 8 + 2*1 + 2*2 + 2*3 = 20.

 

Ответ: 20.