СДАМ ГИА: РЕШУ ОГЭ
Образовательный портал для подготовки к экзаменам
Информатика
информатика
сайты - меню - вход - новости


Задания
Версия для печати и копирования в MS Word
Задания Д9 № 867

За­пи­ши­те зна­че­ние пе­ре­мен­ной s, по­лу­чен­ное в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей про­грам­мы. Текст про­грам­мы при­ведён на пяти язы­ках про­грам­ми­ро­ва­ния.

 

Бей­сикPython

DIM n, s AS INTEGER

s = 0

FOR n = 3 TO 7

    s = s + 2*n

NEXT n

PRINT s

s = 0

for n in range(3,8):

    s = s + 2*n

print (s)

Пас­кальАл­го­рит­ми­че­ский язык

var s,n: integer;

begin

    s := 0;

    for n := 3 to 7 do

        s := s + 2*n;

    writeln(s);

end.

алг

нач

   цел s, n

   s := 0

   нц для n от 3 до 7

      s := s + 2*n

   кц

   вывод s

кон

С++

#include <iostream>

using namespace std;

int main() {

     int s = 0;

     for (int n = 3; n <= 7; n++)

          s = s + 2*n;

     cout << s;

     return 0;

}

 

Ре­ше­ние.

Цикл for n := 3 to 7 do вы­пол­ня­ет­ся 5 раз. Каж­дый раз пе­ре­мен­ная s умно­жа­ет­ся на 2*n. по­сколь­ку из­на­чаль­но зна­че­ние s равно 0, после вы­пол­не­ния про­грам­мы по­лу­чим s = 2*3+2*4+2*5+2*6+2*7 = 50.

 

Ответ: 50.