СДАМ ГИА: РЕШУ ОГЭ
Образовательный портал для подготовки к экзаменам
Информатика
информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 9 № 867

Запишите зна­че­ние пе­ре­мен­ной s, по­лу­чен­ное в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей программы. Текст про­грам­мы приведён на пяти язы­ках программирования.

 

БейсикPython

DIM n, s AS INTEGER

s = 0

FOR n = 3 TO 7

    s = s + 2*n

NEXT n

PRINT s

s = 0

for n in range(3,8):

    s = s + 2*n

print (s)

ПаскальАлгоритмический язык

var s,n: integer;

begin

    s := 0;

    for n := 3 to 7 do

        s := s + 2*n;

    writeln(s);

end.

алг

нач

   цел s, n

   s := 0

   нц для n от 3 до 7

      s := s + 2*n

   кц

   вывод s

кон

С++

#include <iostream>

using namespace std;

int main() {

     int s = 0;

     for (int n = 3; n <= 7; n++)

          s = s + 2*n;

     cout << s;

     return 0;

}

 

Решение.

Цикл for n := 3 to 7 do выполняется 5 раз. Каждый раз переменная s умножается на 2*n. поскольку изначально значение s равно 0, после выполнения программы получим s = 2*3+2*4+2*5+2*6+2*7 = 50.

 

Ответ: 50.