СДАМ ГИА: РЕШУ ОГЭ
Образовательный портал для подготовки к экзаменам
Информатика
информатика
сайты - меню - вход - новости


Задания
Версия для печати и копирования в MS Word
Задание 15 № 858

Выберите ОДНО из предложенных ниже заданий: 15.1 или 15.2.

 

15.1 Исполнитель Робот умеет перемещаться по лабиринту, начерченному на плоскости, разбитой на клетки. Между соседними (по сторонам) клетками может стоять стена, через которую Робот пройти не может.

У Робота есть девять команд. Четыре команды — это команды-приказы:

 

вверх вниз влево вправо

 

При выполнении любой из этих команд Робот перемещается на одну клетку соответственно: вверх ↑ вниз ↓, влево ← , вправо →. Если Робот получит команду передвижения сквозь стену, то он разрушится.

Также у Робота есть команда закрасить, при которой закрашивается клетка, в которой Робот находится в настоящий момент.

Ещё четыре команды —  это команды проверки условий. Эти команды проверяют, свободен ли путь для Робота в каждом из четырёх возможных направлений:

 

сверху свободно  снизу свободно  слева свободно  справа свободно

 

Эти команды можно использовать вместе с условием «если», имеющим следующий вид:

 

если условие то

последовательность команд

все

 

Здесь условие — одна из команд проверки условия. Последовательность команд — это одна или несколько любых команд-приказов. Например, для передвижения на одну клетку вправо, если справа нет стенки, и закрашивания клетки можно использовать такой алгоритм:

если справа свободно то

вправо

закрасить

все

 

В одном условии можно использовать несколько команд проверки условий, применяя логические связки и, или, не, например:

 

если (справа свободно) и (не снизу свободно) то

вправо

все

 

Для повторения последовательности команд можно использовать цикл «пока», имеющий следующий вид:

 

нц пока условие

последовательность команд

кц

 

Например, для движения вправо, пока это возможно, можно использовать следующий алгоритм:

 

нц пока справа свободно

вправо

кц

 

Выполните задание.

На бесконечном поле имеются четыре стены, соединённые между собой, которые образуют прямоугольник. Длины стен неизвестны. В левой вертикальной стене есть ровно один проход, в нижней горизонтальной стене

также есть ровно один проход. Проход не может примыкать к углу прямоугольника. Точные места проходов и ширина проходов неизвестны. Робот находится около нижнего конца левой вертикальной стены, снаружи прямоугольника и выше нижней стены. На рисунке указан один из возможных способов расположения стен и Робота (Робот обозначен буквой «Р»).

 

Напишите для Робота алгоритм, закрашивающий все клетки, расположенные вдоль стен прямоугольника с внутренней стороны. Проходы должны остаться незакрашенными. Робот должен закрасить только клетки, удовлетворяющие данному условию. Например, для приведённого выше рисунка Робот должен закрасить следующие клетки (см. рисунок).

 

 

При исполнении алгоритма Робот не должен разрушиться, выполнение алгоритма должно завершиться. Конечное расположение Робота может быть произвольным. Алгоритм должен решать задачу для любого допустимого

расположения стен и любого расположения и размера прохода внутри стены. Алгоритм может быть выполнен в среде формального исполнителя или записан в текстовом редакторе.

 

 

 

 

 

 

 

 

15.2 Напишите программу, которая в последовательности натуральных чисел определяет минимальное чётное число.

Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется чётное число. Количество чисел не превышает 1000. Введённые числа не превышают 30 000.

Программа должна вывести одно число — минимальное чётное число.

 

Пример работы программы:

 

Входные данныеВыходные данные

4

3

20

6

8

6

Решение.

15.1 Команды исполнителя будем записывать жирным шрифтом, а комментарии, поясняющие алгоритм и не являющиеся его частью, —курсивом. Начало комментария будем обозначать символом «|».

 

| Двигаемся вверх, пока не дойдём до прохода в стене,

нц пока не справа свободно

вверх

кц

 

| Через проход входим внутрь прямоугольника

вправо

 

| Двигаемся вниз до нижней стены, закрашивая все клетки на пути

нц пока снизу свободно

вниз

закрасить

кц

 

| Двигаемся вправо, вдоль стены до прохода, закрашиваем все клетки на пути

нц пока не снизу свободно

закрасить

вправо

кц

 

| Двигаемся вправо, пересекаем проход в стене

нц пока снизу свободно

вправо

кц

 

| Двигаемся вправо, вдоль стены до конца стены, закрашиваем все клетки на пути

нц пока справа свободно

закрасить

вправо

кц

 

| Двигаемся вверх, вдоль вертикальной стены, закрашиваем все клетки на пути

нц пока сверху свободно

закрасить

вверх

кц

 

| Двигаемся влево, вдоль верхней горизонтальной стены, закрашиваем все клетки на пути

нц пока слева свободно

закрасить

влево

кц

 

| Двигаемся вниз, вдоль стены, до прохода в стене, закрашиваем все клетки на пути

нц пока не слева свободно

закрасить

вниз

кц

 

Возможны и другие варианты решения.

 

15.2 Решением является программа, записанная на любом языке программирования. Пример верного решения, записанного на языке Паскаль:

 

var n,i,a,min: integer;

begin

readln(n);

min := 30001;

for i := 1 to n do

begin

readln(a);

if (a mod 2 = 0) and (a < min)

then min:= a;

end;

writeln(min)

end.

 

Возможны и другие варианты решения. Для проверки правильности работы программы необходимо использовать следующие тесты:

 

Входные данныеВыходные данные
1

3

10

4

19

4
2

3

11

22

44

22
3

3

9

11

2

2