СДАМ ГИА: РЕШУ ОГЭ
Образовательный портал для подготовки к экзаменам
Информатика
информатика
сайты - меню - вход - новости


Задания
Версия для печати и копирования в MS Word
Задания Д17 C1 № 857

В электронную таблицу занесли данные о стоимости и комплектации кондитерских изделий. Ниже приведены первые шесть строк таблицы.

 

 

В столбце A указан артикул товара; в столбце B — наименование товара; в столбце C — вес единицы товара; в столбце D — количество единиц товара в упаковке; в столбце E — цена за единицу товара.

Всего в электронную таблицу были занесены данные по 1443 наименованиям.

 

 

task19.xls

 

Выполните задание.

Откройте файл с данной электронной таблицей. На основании данных, содержащихся в этой таблице, ответьте на два вопроса.

 

1. Какой процент от общего количества наименований составляют товары стоимостью менее 100 рублей за одну штуку? Ответ на этот вопрос запишите в ячейку H1 таблицы с точностью не менее одного знака после запятой.

2. Сколько имеется таких наименований товаров из предложенной таблицы, что они весят менее 100 граммов и упакованы по 20 штук?

 

Ответ запишите в ячейку H2 таблицы.

 

Примечание. При решении допускается использование любых возможностей электронных таблиц. Допускаются вычисления при помощи ручки и бумаги. Использование калькуляторов не допускается.

Решение.

Алгоритмы решения задач для OpenOffice.org Calc и Microsoft Excel совпадают. Формулы написаны для обеих электронных таблиц. Второй вариант — для OpenOffice.org Calc.

 

В ячейке H1 запишем формулу

=СЧЁТЕСЛИ(E2:E1444;"<100")/1443

=COUNTIF(E2:E1444;"<100")/1443

Затем выразим полученное значение в процентах и установим один знак после запятой.

 

Для ответа на второй вопрос в ячейке G2 запишем формулу

=ЕСЛИ(И(C2<100;D2=20);1;0)

=IF(AND(C2<100;D2=20);1;0)

Скопируем эту формулу во все ячейки диапазона G3:G1444.

В ячейках, где выполняются требуемые условия, появится значение 1, в остальных — 0.

Посчитаем количество единиц, для этого в ячейке H2 запишем

=СУММ(G2:G1444)

=SUM(G2:G1444)

 

Возможны и другие способы решения задачи.

Если задание выполнено правильно и для его выполнения использовались файлы, специально подготовленные для данного задания, то должны получиться следующие ответы:

на первый вопрос — 51,4;

на второй вопрос — 25.