информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 9 № 847

Запишите зна­че­ние пе­ре­мен­ной s, по­лу­чен­ное в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей программы. Текст про­грам­мы приведён на пяти язы­ках программирования.

 

БейсикPython

DIM n, s AS INTEGER

s = 1

FOR n = 2 TO 5

    s = s * 3

NEXT n

PRINT s

s = 1

for n in range(2,6):

    s = s * 3

print (s)

ПаскальАлгоритмический язык

var s,n: integer;

begin

    s := 1;

    for n := 2 to 5 do

        s := s * 3;

    writeln(s);

end.

алг

нач

   цел s, n

   s := 1

   нц для n от 2 до 5

      s := s * 3

   кц

   вывод s

кон

С++

#include <iostream>

using namespace std;

int main() {

     int s = 1;

     for (int n = 2; n <= 5; n++)

          s = s * 3;

     cout << s;

     return 0;

}

 

Пояснение.

Цикл for n := 2 to 5 do выполняется 4 раза. Каждый раз переменная s умножается на 3. поскольку изначально значение s равно 1, после выполнения программы получим s = 34 = 81.

 

Ответ: 81.