Задания
Версия для печати и копирования в MS Word
Тип 15 № 836

Выберите ОДНО из предложенных ниже заданий: 15.1 или 15.2.

 

15.1 Исполнитель Робот умеет перемещаться по лабиринту, начерченному на плоскости, разбитой на клетки. Между соседними (по сторонам) клетками может стоять стена, через которую Робот пройти не может.

У Робота есть девять команд. Четыре команды — это команды-приказы:

вверх вниз влево вправо

При выполнении любой из этих команд Робот перемещается на одну клетку соответственно: вверх ↑ вниз ↓, влево ← , вправо →. Если Робот получит команду передвижения сквозь стену, то он разрушится.

Также у Робота есть команда закрасить, при которой закрашивается клетка, в которой Робот находится в настоящий момент.

Ещё четыре команды —  это команды проверки условий. Эти команды проверяют, свободен ли путь для Робота в каждом из четырёх возможных направлений:

сверху свободно  снизу свободно  слева свободно  справа свободно

Эти команды можно использовать вместе с условием «если», имеющим следующий вид:

 

если условие то

последовательность команд

все

 

Здесь условие — одна из команд проверки условия. Последовательность команд — это одна или несколько любых команд-приказов. Например, для передвижения на одну клетку вправо, если справа нет стенки, и закрашивания клетки можно использовать такой алгоритм:

если справа свободно то

вправо

закрасить

все

 

В одном условии можно использовать несколько команд проверки условий, применяя логические связки и, или, не, например:

 

если (справа свободно) и (не снизу свободно) то

вправо

все

 

Для повторения последовательности команд можно использовать цикл «пока», имеющий следующий вид:

 

нц пока условие

последовательность команд

кц

 

Например, для движения вправо, пока это возможно, можно использовать следующий алгоритм:

 

нц пока справа свободно

вправо

кц

 

Выполните задание.

На бесконечном поле имеется стена, длины отрезков стены неизвестны. Стена состоит из двух вертикальных и соединяющего их горизонтального отрезков (отрезки стены расположены "буквой П"). В горизонтальном участке есть ровно один проход, место и длина прохода неизвестны. Робот находится в клетке, расположенной над правым концом горизонтального отрезка стены.

На рисунке указан один из возможных способов расположения стен и Робота

(Робот обозначен буквой «Р»).

 

Напишите для Робота алгоритм, закрашивающий все клетки, расположенные над горизонтальным отрезком стены слева от прохода, и все клетки, расположенные с внешней стороны от левого вертикального участка стены. Робот должен закрасить только клетки, удовлетворяющие данному условию.

Например, для приведённого справа рисунка Робот должен закрасить следующие клетки (см. рис.).

 

 

Конечное расположение Робота может быть произвольным. При исполнении алгоритма Робот не должен разрушиться.

 

Алгоритм должен решать задачу для произвольного размера поля, любого допустимого расположения стен и любого расположения и размера прохода.

 

 

 

 

 

 

 

 

 

 

15.2 Напишите программу, которая в последовательности натуральных чисел определяет сумму всех чисел, кратных 4 и оканчивающихся на 8. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). Количество чисел не превышает 100. Введённые числа не превышают 300. Программа должна вывести одно число: сумму всех чисел, кратных 4 и оканчивающихся на 8.

 

Пример работы программы:

 

Входные данныеВыходные данные

8

22

16

28

18

0

36
Спрятать решение

Решение.

15.1 Команды исполнителя будем записывать жирным шрифтом, а комментарии –

курсивом. Начало комментария будем обозначать символом "|" .

 

|Двигаемся влево, пока не дойдем до прохода

нц пока не (снизу свободно)

влево

кц

 

|Двигаемся влево по проходу

нц пока (снизу свободно)

влево

кц

 

|Двигаемся влево и закрашиваем клетки над горизонтальной линией после прохода

нц пока не (снизу свободно)

закрасить

влево

кц

 

|Двигаемся вниз, чтобы оказаться у внешней стороны правого вертикального отрезка стены

вниз

 

|Двигаемся вниз и закрашиваем оставшиеся клетки

нц пока не (справа свободно)

закрасить

вниз

кц

 

Возможны и другие варианты решения.

 

15.2 Решением является программа, записанная на любом языке программирования. Пример верного решения, записанного на языке Паскаль:

 

var a, s: integer;

begin

s := 0;

readln(a);

while a<>0 do

begin

if (a mod 4 = 0) and (a mod 10 = 8) then

s := s + a;

readln(a);

end;

writeln(s);

end.

 

Возможны и другие варианты решения. Для проверки правильности работы программы необходимо использовать следующие тесты:

 

Входные данныеВыходные данные
1

8

28

0

36
2

40

0

0
3

18

0

0
4

23

28

0

28
Спрятать критерии
Критерии проверки:

Критерии оценивания выполнения задания 15.1Баллы
Алгоритм правильно работает при всех допустимых исходных данных2
При всех допустимых исходных данных верно следующее:

1) выполнение алгоритма завершается, и при этом Робот не разбивается;

2) закрашено не более 10 лишних клеток;

3) остались незакрашенными не более 10 клеток из числа тех, которые должны были быть закрашены

1
Задание выполнено неверно, т. е. не выполнены условия, позволяющие поставить 1 или 2 балла0
Максимальный балл2

 

Критерии оценивания выполнения задания 15.2Баллы
Предложено верное решение. Программа правильно работает на всех приведённых выше тестах. Программа может быть записана на любом языке программирования2
Программа выдаёт неверный ответ на одном из тестов, приведённых выше. Например, решение, в котором не задано условие отбора чисел (a mod 10 = 8), выдаст неправильный ответ на тесте №2 1
Программа выдаёт на тестах неверные ответы, отличные от описанных в критерии на 1 балл0
Максимальный балл2
Спрятать решение · ·
Nikita Shestakov 10.05.2017 16:32

В 4 тесте в выходных данных должно быть написано 28, а не 12.