информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 20 № 836

Выберите ОДНО из пред­ло­жен­ных ниже заданий: 20.1 или 20.2.

 

20.1 Ис­пол­ни­тель Робот умеет пе­ре­ме­щать­ся по лабиринту, на­чер­чен­но­му на плоскости, раз­би­той на клетки. Между со­сед­ни­ми (по сторонам) клет­ка­ми может сто­ять стена, через ко­то­рую Робот прой­ти не может.

У Ро­бо­та есть де­вять команд. Че­ты­ре команды — это команды-приказы:

 

вверх вниз влево вправо

 

При вы­пол­не­нии любой из этих ко­манд Робот пе­ре­ме­ща­ет­ся на одну клет­ку соответственно: вверх ↑ вниз ↓, влево ← , впра­во →. Если Робот по­лу­чит ко­ман­ду пе­ре­дви­же­ния сквозь стену, то он разрушится.

Также у Ро­бо­та есть ко­ман­да закрасить, при ко­то­рой за­кра­ши­ва­ет­ся клетка, в ко­то­рой Робот на­хо­дит­ся в на­сто­я­щий момент.

Ещё че­ты­ре команды —  это ко­ман­ды про­вер­ки условий. Эти ко­ман­ды проверяют, сво­бо­ден ли путь для Ро­бо­та в каж­дом из четырёх воз­мож­ных направлений:

 

сверху свободно  снизу свободно  слева свободно  спра­ва свободно

 

Эти ко­ман­ды можно ис­поль­зо­вать вме­сте с усло­ви­ем «если», име­ю­щим сле­ду­ю­щий вид:

 

если условие то

последовательность команд

все

 

Здесь условие — одна из ко­манд про­вер­ки условия. Последовательность команд — это одна или не­сколь­ко любых команд-приказов. Например, для пе­ре­дви­же­ния на одну клет­ку вправо, если спра­ва нет стенки, и за­кра­ши­ва­ния клет­ки можно ис­поль­зо­вать такой алгоритм:

если спра­ва сво­бод­но то

вправо

закрасить

все

 

В одном усло­вии можно ис­поль­зо­вать не­сколь­ко ко­манд про­вер­ки условий, при­ме­няя ло­ги­че­ские связ­ки и, или, не, например:

 

если (справа свободно) и (не снизу свободно) то

вправо

все

 

Для по­вто­ре­ния по­сле­до­ва­тель­но­сти ко­манд можно ис­поль­зо­вать цикл «пока», име­ю­щий сле­ду­ю­щий вид:

 

нц пока условие

последовательность команд

кц

 

Например, для дви­же­ния вправо, пока это возможно, можно ис­поль­зо­вать сле­ду­ю­щий алгоритм:

 

нц пока спра­ва сво­бод­но

вправо

кц

 

Выполните задание.

На бес­ко­неч­ном поле име­ет­ся стена, длины от­рез­ков стены неизвестны. Стена со­сто­ит из двух вер­ти­каль­ных и со­еди­ня­ю­ще­го их го­ри­зон­таль­но­го от­рез­ков (отрезки стены рас­по­ло­же­ны "буквой П"). В го­ри­зон­таль­ном участ­ке есть ровно один проход, место и длина про­хо­да неизвестны. Робот на­хо­дит­ся в клетке, рас­по­ло­жен­ной над пра­вым кон­цом го­ри­зон­таль­но­го от­рез­ка стены.

На ри­сун­ке ука­зан один из воз­мож­ных спо­со­бов рас­по­ло­же­ния стен и Робота

(Робот обо­зна­чен бук­вой «Р»).

 

Напишите для Ро­бо­та алгоритм, за­кра­ши­ва­ю­щий все клетки, рас­по­ло­жен­ные над го­ри­зон­таль­ным от­рез­ком стены слева от прохода, и все клетки, рас­по­ло­жен­ные с внеш­ней сто­ро­ны от ле­во­го вер­ти­каль­но­го участ­ка стены. Робот дол­жен за­кра­сить толь­ко клетки, удо­вле­тво­ря­ю­щие дан­но­му условию.

Например, для приведённого спра­ва ри­сун­ка Робот дол­жен за­кра­сить сле­ду­ю­щие клет­ки (см. рисунок).

 

 

Конечное рас­по­ло­же­ние Ро­бо­та может быть произвольным. При ис­пол­не­нии ал­го­рит­ма Робот не дол­жен разрушиться.

 

Алгоритм дол­жен ре­шать за­да­чу для про­из­воль­но­го раз­ме­ра поля, лю­бо­го до­пу­сти­мо­го рас­по­ло­же­ния стен и лю­бо­го рас­по­ло­же­ния и раз­ме­ра прохода.

 

 

 

 

 

 

 

 

 

 

20.2 На­пи­ши­те программу, ко­то­рая в по­сле­до­ва­тель­но­сти на­ту­раль­ных чисел опре­де­ля­ет сумму всех чисел, крат­ных 4 и окан­чи­ва­ю­щих­ся на 8. Про­грам­ма по­лу­ча­ет на вход на­ту­раль­ные числа, ко­ли­че­ство введённых чисел неизвестно, по­сле­до­ва­тель­ность чисел за­кан­чи­ва­ет­ся чис­лом 0 (0 – при­знак окон­ча­ния ввода, не вхо­дит в последовательность). Ко­ли­че­ство чисел не пре­вы­ша­ет 100. Введённые числа не пре­вы­ша­ют 300. Про­грам­ма долж­на вы­ве­сти одно число: сумму всех чисел, крат­ных 4 и окан­чи­ва­ю­щих­ся на 8.

 

Пример ра­бо­ты программы:

 

Входные данныеВыходные данные

8

22

16

28

18

0

36

Пояснение.

20.1 Ко­ман­ды ис­пол­ни­те­ля будем за­пи­сы­вать жир­ным шрифтом, а ком­мен­та­рии –

курсивом. На­ча­ло ком­мен­та­рия будем обо­зна­чать сим­во­лом "|" .

 

|Двигаемся влево, пока не дой­дем до прохода

нц пока не (снизу свободно)

влево

кц

 

|Двигаемся влево по проходу

нц пока (снизу свободно)

влево

кц

 

|Двигаемся влево и за­кра­ши­ва­ем клет­ки над го­ри­зон­таль­ной ли­ни­ей после прохода

нц пока не (снизу свободно)

закрасить

влево

кц

 

|Двигаемся вниз, чтобы ока­зать­ся у внеш­ней сто­ро­ны пра­во­го вер­ти­каль­но­го от­рез­ка стены

вниз

 

|Двигаемся вниз и за­кра­ши­ва­ем остав­ши­е­ся клетки

нц пока не (справа свободно)

закрасить

вниз

кц

 

Возможны и дру­гие ва­ри­ан­ты решения.

 

20.2 Ре­ше­ни­ем яв­ля­ет­ся программа, за­пи­сан­ная на любом языке программирования. При­мер вер­но­го решения, за­пи­сан­но­го на языке Паскаль:

 

var a, s: integer;

begin

s := 0;

readln(a);

while a<>0 do

begin

if (a mod 4 = 0) and (a mod 10 = 8) then

s := s + a;

readln(a);

end;

writeln(s)

end.

 

Возможны и дру­гие ва­ри­ан­ты решения. Для про­вер­ки пра­виль­но­сти ра­бо­ты про­грам­мы не­об­хо­ди­мо ис­поль­зо­вать сле­ду­ю­щие тесты:

 

Входные данныеВыходные данные
1

8

28

0

36
2

40

0

0
3

18

0

0
4

23

28

0

28
Источник: МИОО: Ди­а­гно­сти­че­ская работа по ин­фор­ма­ти­ке 06.03.2014 ва­ри­ант ИН90702.
Спрятать пояснение · ·
Nikita Shestakov 10.05.2017 19:32
В 4 тесте в выходных данных должно быть написано 28, а не 12.