СДАМ ГИА: РЕШУ ОГЭ
Образовательный портал для подготовки к экзаменам
Информатика
информатика
сайты - меню - вход - новости


Задания
Версия для печати и копирования в MS Word
Задания Д8 № 805

Запишите значение переменной f, полученное в результате работы следующей программы. Текст программы приведён на пяти языках программирования.

 

БейсикPython

DIM f, n AS INTEGER

f = 4

f = f*3

FOR n = 1 TO 4

    f = f + n

NEXT n

PRINT f

f = 4

f = f*3

for n in range(1,5):

    f = f + n

print (f)

ПаскальАлгоритмический язык

var f, n: integer;

begin

    f := 4;

    f := f*3;

    for n := 1 to 4 do

        f := f + n;

    writeln(f);

end.

алг

нач

   цел f, n

   f := 4;

   f := f*3;

   нц для n от 1 до 4

      f := f + n

   кц

   вывод f

кон

С++

#include <iostream>

using namespace std;

int main() {

    int f = 4;

    f = f*3;

    for (int n = 1; n <= 4; n++)

         f = f + n;

    cout << f;

    return 0;

}

 

Решение.

Цикл «for n := 1 to 4 do» выполняется четыре раза. Каждый раз переменная f увеличивается на n. Поскольку изначально f = 4 · 3 = 12, после выполнения программы получим: f = 12 + 1 + 2 + 3 + 4 = 22.

 

Ответ: 22.