информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 9 № 805

Запишите зна­че­ние пе­ре­мен­ной f, по­лу­чен­ное в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей программы. Текст про­грам­мы приведён на пяти язы­ках программирования.

 

БейсикPython

DIM f, n AS INTEGER

f = 4

f = f*3

FOR n = 1 TO 4

    f = f + n

NEXT n

PRINT f

f = 4

f = f*3

for n in range(1,5):

    f = f + n

print (f)

ПаскальАлгоритмический язык

var f, n: integer;

begin

    f := 4;

    f := f*3;

    for n := 1 to 4 do

        f := f + n;

    writeln(f);

end.

алг

нач

   цел f, n

   f := 4;

   f := f*3;

   нц для n от 1 до 4

      f := f + n

   кц

   вывод f

кон

С++

#include <iostream>

using namespace std;

int main() {

    int f = 4;

    f = f*3;

    for (int n = 1; n <= 4; n++)

         f = f + n;

    cout << f;

    return 0;

}

 

Пояснение.

Цикл «for n := 1 to 4 do» вы­пол­ня­ет­ся че­ты­ре раза. Каж­дый раз пе­ре­мен­ная f уве­ли­чи­ва­ет­ся на n. По­сколь­ку из­на­чаль­но f = 4 · 3 = 12, после вы­пол­не­ния про­грам­мы по­лу­чим: f = 12 + 1 + 2 + 3 + 4 = 22.

 

Ответ: 22.