информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 19 № 79

В элек­трон­ную таблицу за­нес­ли данные о те­сти­ро­ва­нии учеников. Ниже при­ве­де­ны первые пять строк таблицы:

 

ABCD
1округфамилияпредметбалл
2CУченик 1обществознание246
3ВУченик 2немецкий язык530
4ЮУченик 3русский язык576
5СВУченик 4обществознание304

 

В столб­це А за­пи­сан округ, в ко­то­ром учится ученик; в столб­це В — фамилия; в столб­це С — любимый предмет; в столб­це D — тестовый балл. Всего в элек­трон­ную таблицу были за­не­се­ны данные по 1000 ученикам.

 

Выполните задание.

Откройте файл с дан­ной электронной таб­ли­цей (расположение файла Вам со­об­щат организаторы экзамена). На ос­но­ва­нии данных, со­дер­жа­щих­ся в этой таблице, от­веть­те на два вопроса.

1. Сколько уче­ни­ков в Цен­траль­ном округе (Ц) вы­бра­ли в ка­че­стве любимого пред­ме­та английский язык? Ответ на этот во­прос запишите в ячей­ку Н2 таблицы.

2. Каков сред­ний тестовый балл у уче­ни­ков Восточного окру­га (В)? Ответ на этот во­прос запишите в ячей­ку Н3 таб­ли­цы с точ­но­стью не менее двух зна­ков после запятой.

 

 

task19.xls

Пояснение.

task19.xls

 

1. За­пи­шем в ячей­ку H2 сле­ду­ю­щую формулу =ЕСЛИ(A2="Ц";C2;0) и ско­пи­ру­ем ее в диа­па­зон H3:H1001. В таком случае, в ячей­ку столбца Н будет за­пи­сы­вать­ся название предмета, если уче­ник из Цен­траль­но­го округа и «0», если это не так. При­ме­нив операцию =ЕСЛИ(H2="английский язык";1;0), по­лу­чим столбец(J) с еди­ни­ца­ми и нулями. Далее, ис­поль­зу­ем операцию =СУММ(J2:J1001). По­лу­чим количество учеников, ко­то­рые считают своим лю­би­мым предметом ан­глий­ский язык. Таких 20 человек.

2. Для от­ве­та на вто­рой вопрос ис­поль­зу­ем операцию «ЕСЛИ». За­пи­шем в ячей­ку E2 сле­ду­ю­щее выражение: =ЕСЛИ(A2="В";D2;0), в ре­зуль­та­те применения дан­ной операции к диа­па­зо­ну ячеек Е2:Е1001, по­лу­чим столбец, в ко­то­ром записаны баллы толь­ко учеников из Во­сточ­но­го округа. Про­сум­ми­ро­вав значения в ячейках, по­лу­чим сумму бал­лов учеников: 66 012. Далее по­счи­та­ем количество уче­ни­ков из Во­сточ­но­го округа с по­мо­щью команды =СЧЁТЕСЛИ(A2:A1001;"В"), получим: 132. Раз­де­лив сумму бал­лов на ко­ли­че­ство учеников, получим: 500,09 — искомый сред­ний балл.

 

Ответ: 1) 20; 2) 500,09.

Источник: ГИА по информатике 31.05.2013. Основная волна. Центр, Урал. Вариант 1304.