СДАМ ГИА: РЕШУ ОГЭ
Образовательный портал для подготовки к экзаменам
Информатика
информатика
сайты - меню - вход - новости


Задания
Версия для печати и копирования в MS Word
Задание 19 № 783

Ваня Ива­нов со­би­рал­ся по­ле­теть на ка­ни­ку­лах на отдых и за­пи­сал рас­пи­са­ние перелётов из Моск­вы в раз­ные го­ро­да в виде таб­ли­цы. Ниже при­ве­де­ны пер­вые пять строк таб­ли­цы.

 

АB C
1ГородСтра­на При­мер­ное время в пути
2Аба­канРОС­СИЯ4
3Абу-Даби ОАЭ5
4Адлер РОС­СИЯ 2
5Акаба ЕГИ­ПЕТ5

 

Каж­дая стро­ка таб­ли­цы со­дер­жит за­пись об одном марш­ру­те перелёта. В столб­це A за­пи­сан город на­зна­че­ния, в столб­це B — стра­на на­зна­че­ния; в столб­це C — при­мер­ное время в пути. Всего в элек­трон­ную таб­ли­цу были за­не­се­ны дан­ные по 191 марш­ру­ту в ал­фа­вит­ном по­ряд­ке.

 

Вы­пол­ни­те за­да­ние.

От­крой­те файл с дан­ной элек­трон­ной таб­ли­цей (рас­по­ло­же­ние файла Вам со­об­щат ор­га­ни­за­то­ры эк­за­ме­на). На ос­но­ва­нии дан­ных, со­дер­жа­щих­ся в этой таб­ли­це, от­веть­те на два во­про­са.

1. Для ка­ко­го ко­ли­че­ства го­ро­дов расчётное время перелёта со­став­ля­ет более 5 часов? Ответ на этот во­прос за­пи­ши­те в ячей­ку H2 таб­ли­цы.

2. Какой про­цент от всех 6-ча­со­вых перёлетов со­став­ля­ют 6-ча­со­вые перелёты в го­ро­да Рос­сии? Ответ на этот во­прос в виде це­ло­го числа нужно за­пи­сать в ячей­ку H3 таб­ли­цы.

 

task19.xls

Решение.

1. В ячей­ку H2 за­пи­шем формулу, определяющую, в какое ко­ли­че­ство го­ро­дов можно до­ле­теть более, чем за 5 часов: =СЧЁТЕСЛИ(C2:C192;">5").

2. Для от­ве­та на вто­рой вопрос, в столб­це G для каж­до­го перелёта за­пи­шем стра­ну назначения, если время пе­ре­ле­та 6 часов и 0 в об­рат­ном случае. В ячей­ку G2 за­пи­шем формулу: =ЕСЛИ(C2=6;B2;0).

Скопируем фор­му­лу во все ячей­ки диа­па­зо­на G3:G192. Далее, чтобы опре­де­лить пе­ре­ле­ты по России, за­пи­шем в ячей­ку I1 формулу: =СЧЁТЕСЛИ(G2:G192;"РОССИЯ").

Посчитаем общее ко­ли­че­ство 6-часовых перелетов. В ячей­ку I2 за­пи­шем формулу: =СЧЁТЕСЛИ(C2:C192;6).

Выразим по­лу­чен­ное зна­че­ние в про­цен­тах от об­ще­го числа всех 6-часовых перелётов. Ре­зуль­тат за­пи­шем в ячей­ку H3: =I1*100/I2.

Допускаются и дру­гие спо­со­бы решения, на­при­мер с ис­поль­зо­ва­ни­ем сортировок, филь­тров и т.д.

 

Ответ на пер­вый вопрос: 41. Ответ на вто­рой вопрос: 50.