информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 9 № 773

Запишите зна­че­ние пе­ре­мен­ной d, по­лу­чен­ное в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей программы. Текст про­грам­мы приведён на пяти язы­ках программирования.

 

БейсикPython

DIM d, n AS INTEGER

d = 5

d = d−3

FOR n = 1 TO 4

    d = d + n

NEXT n

PRINT d

d = 5

d = d−3

for n in range(1,5):

    d = d + n

print (d)

ПаскальАлгоритмический язык

var d, n: integer;

begin

    d := 5;

    d := d−3;

    for n := 1 to 4 do

        d := d + n;

    writeln(d);

end.

алг

нач

   цел d, n

   d := 5;

   d := d−3;

   нц для n от 1 до 4

      d := d + n

   кц

   вывод d

кон

С++

#include <iostream>

using namespace std;

int main() {

    int d = 5;

    d = d−3;

    for (int n = 1; n <= 4; n++)

         d = d + n;

    cout << d;

    return 0;

}

 

Пояснение.

Цикл «for k := 1 to 4 do» вы­пол­ня­ет­ся че­ты­ре раза. Каж­дый раз пе­ре­мен­ная d уве­ли­чи­ва­ет­ся на n. По­сколь­ку из­на­чаль­но d = 5 − 3 = 2, после вы­пол­не­ния про­грам­мы по­лу­чим: d = 2 + 1 + 2 + 3 + 4 = 12.

 

Ответ: 12.