СДАМ ГИА: РЕШУ ОГЭ
Образовательный портал для подготовки к экзаменам
Информатика
информатика
сайты - меню - вход - новости


Задания
Версия для печати и копирования в MS Word
Задание 15 № 764

Выберите ОДНО из предложенных ниже заданий: 15.1 или 15.2.

 

15.1 Исполнитель Робот умеет перемещаться по лабиринту, начерченному на плоскости, разбитой на клетки. Между соседними (по сторонам) клетками может стоять стена, через которую Робот пройти не может.

У Робота есть девять команд. Четыре команды — это команды-приказы:

 

вверх вниз влево вправо

 

При выполнении любой из этих команд Робот перемещается на одну клетку соответственно: вверх ↑ вниз ↓, влево ← , вправо →. Если Робот получит команду передвижения сквозь стену, то он разрушится.

Также у Робота есть команда закрасить, при которой закрашивается клетка, в которой Робот находится в настоящий момент.

Ещё четыре команды —  это команды проверки условий. Эти команды проверяют, свободен ли путь для Робота в каждом из четырёх возможных направлений:

 

сверху свободно  снизу свободно  слева свободно  справа свободно

 

Эти команды можно использовать вместе с условием «если», имеющим следующий вид:

если условие то

последовательность команд

все

 

Здесь условие — одна из команд проверки условия. Последовательность команд — это одна или несколько любых команд-приказов. Например, для передвижения на одну клетку вправо, если справа нет стенки, и закрашивания клетки можно использовать такой алгоритм:

если справа свободно то

вправо

закрасить

все

 

В одном условии можно использовать несколько команд проверки условий, применяя логические связки и, или, не, например:

если (справа свободно) и (не снизу свободно) то

вправо

все

Для повторения последовательности команд можно использовать цикл «пока», имеющий следующий вид:

нц пока условие

последовательность команд

кц

 

Например, для движения вправо, пока это возможно, можно использовать следующий алгоритм:

нц пока справа свободно

вправо

кц

 

Выполните задание.

На бесконечном поле имеется стена, состоящая из трёх последовательных отрезков: вправо, вниз, влево. Все отрезки неизвестной длины. Робот находится в клетке, расположенной в нижнем углу, который образуется вторым и третьим отрезком. На рисунке указан один из возможных способов расположения стены и Робота (Робот обозначен буквой «Р»).

Напишите для Робота алгоритм, закрашивающий все клетки, расположенные ниже третьего отрезка. Робот должен закрасить только клетки, удовлетворяющие данному условию. Например, для приведённого выше рисунка Робот должен закрасить следующие клетки (см. рисунок).

Конечное расположение Робота может быть произвольным. Алгоритм должен решать задачу для бесконечного поля и любого допустимого расположения стен. При исполнении алгоритма Робот не должен разрушиться.

 

 

15.2 Напишите программу, которая в последовательности натуральных чисел определяет сумму всех чисел, кратных 3 и оканчивающихся на 8. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчи- вается числом 0 (0 — признак окончания ввода, не входит в последовательность). Количество чисел не превышает 100. Введённые числа не превышают 300. Программа должна вывести одно число: сумму всех чисел, кратных 3 и оканчивающихся на 8.

 

Пример работы программы:

 

Входные данныеВыходные данные

23

48

12

18

34

0

66

Решение.

15.1 Следующий алгоритм выполнит требуемую задачу.

 

нц пока не (снизу свободно)

влево

кц

вниз

вправо

нц пока не (сверху свободно)

закрасить

вправо

кц

 

Возможны и другие варианты решения.

 

15.2 Решением является программа, записанная на любом языке программирования. Пример верного решения, записанного на языке Паскаль:

 

var a, s: integer;

begin

s:= 0;

readln(a);

while a<>0 do begin

if (a mod 3 = 0) and (a mod 10 = 8) then

s := s + a;

readln(a);

end;

writeln(s)

end.

 

Возможны и другие варианты решения. Для проверки правильности работы программы необходимо использовать следующие тесты:

 

Входные данныеВыходные данные
1

18

21

28

18

0

36
2

77

0

0
3

48

0

48