СДАМ ГИА: РЕШУ ОГЭ
Образовательный портал для подготовки к экзаменам
Информатика
информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 19 № 763

Ваня Ива­нов со­би­рал­ся по­ле­теть на ка­ни­ку­лах на отдых и за­пи­сал рас­пи­са­ние перелётов из Моск­вы в раз­ные го­ро­да в виде таблицы. Ниже при­ве­де­ны пер­вые пять строк таблицы.

 

АB C
1ГородСтрана Примерное время в пути
2АбаканРОССИЯ4
3Абу-Даби ОАЭ5
4Адлер РОССИЯ 2
5Акаба ЕГИПЕТ5

 

Каждая стро­ка таб­ли­цы со­дер­жит за­пись об одном марш­ру­те перелёта. В столб­це A за­пи­сан город назначения, в столб­це B — стра­на назначения; в столб­це C — при­мер­ное время в пути. Всего в элек­трон­ную таб­ли­цу были за­не­се­ны дан­ные по 191 марш­ру­ту в ал­фа­вит­ном порядке.

 

Выполните задание.

Откройте файл с дан­ной элек­трон­ной таб­ли­цей (расположение файла Вам со­об­щат ор­га­ни­за­то­ры экзамена). На ос­но­ва­нии данных, со­дер­жа­щих­ся в этой таблице, от­веть­те на два вопроса.

1. В какое ко­ли­че­ство го­ро­дов можно до­ле­теть менее чем за 4 часа? Ответ на этот во­прос за­пи­ши­те в ячей­ку H2 таблицы.

2. Какой про­цент от всех 5-часовых перелётов со­став­ля­ют 5-часовые пе­ре­ле­ты в Египет? Ответ на этот во­прос нужно за­пи­сать в ячей­ку H3 таб­ли­цы с точ­но­стью од­но­го знака после запятой.

 

 

task19.xls

Пояснение.

1. В ячей­ку H2 за­пи­шем формулу, определяющую, в какое ко­ли­че­ство го­ро­дов можно до­ле­теть менее, чем за 4 часа: =СЧЁТЕСЛИ(C2:C192;"<4").

 

2. Для от­ве­та на вто­рой вопрос, в столб­це G для каж­до­го перелёта за­пи­шем стра­ну назначения, если время перелёта 5 часов и 0 в об­рат­ном случае. В ячей­ку G2 за­пи­шем формулу: =ЕСЛИ(C2=5;B2;0).

Скопируем фор­му­лу во все ячей­ки диа­па­зо­на G3:G192. По­счи­та­ем ко­ли­че­ство 5-часовых перелётов в Египет. Для этого за­пи­шем в ячей­ку I1 формулу: =СЧЁТЕСЛИ(G2:G192;"ЕГИПЕТ").

Посчитаем общее ко­ли­че­ство 5-часовых перелётов. В ячей­ку I2 за­пи­шем формулу: =СЧЁТЕСЛИ(C2:C192;5).

Выразим по­лу­чен­ное зна­че­ние в про­цен­тах от об­ще­го числа всех 5-часовых перелётов. Ре­зуль­тат за­пи­шем в ячей­ку H3: =I1*100/I2.

Допускаются и дру­гие спо­со­бы решения, на­при­мер с ис­поль­зо­ва­ни­ем сортировок, филь­тров и т.д.

 

Ответ на пер­вый вопрос: 111. Ответ на вто­рой вопрос: 12,5.