СДАМ ГИА: РЕШУ ОГЭ
Образовательный портал для подготовки к экзаменам
Информатика
информатика
сайты - меню - вход - новости


Задания
Версия для печати и копирования в MS Word
Задания Д9 № 753

Запишите значение переменной d, полученное в результате работы следующей программы. Текст программы приведён на пяти языках программирования.

 

БейсикPython

DIM d, n AS INTEGER

d = 6

d = d−2

FOR n = 1 TO 4

    d = d + n

NEXT n

PRINT d

d = 6

d = d−2

for n in range(1,5):

    d = d + n

print (d)

ПаскальАлгоритмический язык

var d, n: integer;

begin

    d := 6;

    d := d−2;

    for n := 1 to 4 do

        d := d + n;

    writeln(d);

end.

алг

нач

   цел d, n

   d := 6;

   d := d−2;

   нц для n от 1 до 4

      d := d + n

   кц

   вывод d

кон

С++

#include <iostream>

using namespace std;

int main() {

    int d = 6;

    d = d−2;

    for (int n = 1; n <= 4; n++)

         d = d + n;

    cout << d;

    return 0;

}

 

Решение.

Цикл «for n := 1 to 4 do» выполняется четыре раза. Каждый раз переменная d увеличивается на n. Поскольку изначально d = 6 − 2 = 4, после выполнения программы получим: d = 4 + 1 + 2 + 3 + 4 = 14.

 

Ответ: 14.