СДАМ ГИА: РЕШУ ОГЭ
Образовательный портал для подготовки к экзаменам
Информатика
информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 20 № 701

Выберите ОДНО из пред­ло­жен­ных ниже заданий: 20.1 или 20.2.

 

20.1 Исполнитель Робот умеет пе­ре­ме­щать­ся по лабиринту, на­чер­чен­но­му на плоскости, раз­би­той на клетки. Между со­сед­ни­ми (по сторонам) клет­ка­ми может сто­ять стена, через ко­то­рую Робот прой­ти не может. У Ро­бо­та есть де­вять команд. Че­ты­ре команды — это команды-приказы:

 

вверх вниз влево вправо

 

При вы­пол­не­нии любой из этих ко­манд Робот пе­ре­ме­ща­ет­ся на одну клет­ку соответственно: вверх ↑ вниз ↓, влево ← , впра­во →. Если Робот по­лу­чит команду пе­ре­дви­же­ния сквозь стену, то он разрушится. Также у Ро­бо­та есть ко­ман­да закрасить, при ко­то­рой закрашивается клетка, в ко­то­рой Робот на­хо­дит­ся в на­сто­я­щий момент.

Ещё че­ты­ре команды — это ко­ман­ды проверки условий. Эти ко­ман­ды проверяют, сво­бо­ден ли путь для Ро­бо­та в каж­дом из четырёх воз­мож­ных направлений:

 

сверху свободно  снизу свободно  слева свободно  спра­ва свободно

 

Эти ко­ман­ды можно ис­поль­зо­вать вместе с усло­ви­ем «если», име­ю­щим следующий вид:

если условие то

последовательность команд

все

 

Здесь условие — одна из ко­манд проверки условия. Последовательность команд — это одна или не­сколь­ко любых команд-приказов. Например, для пе­ре­дви­же­ния на одну клет­ку вправо, если спра­ва нет стенки, и за­кра­ши­ва­ния клетки можно ис­поль­зо­вать такой алгоритм:

если спра­ва свободно то

вправо

закрасить

все

 

В одном усло­вии можно ис­поль­зо­вать несколько ко­манд проверки условий, при­ме­няя логические связ­ки и, или, не, например:

если (справа свободно) и (не снизу свободно) то

вправо

все

 

Для по­вто­ре­ния последовательности ко­манд можно ис­поль­зо­вать цикл «пока», име­ю­щий следующий вид:

нц пока условие

последовательность команд

кц

 

Например, для дви­же­ния вправо, пока это возможно, можно ис­поль­зо­вать следующий алгоритм:

нц пока спра­ва свободно

вправо

кц

 

 

Выполните задание.

На бес­ко­неч­ном поле име­ет­ся лестница. Сна­ча­ла лестница под­ни­ма­ет­ся вверх слева направо, потом опус­ка­ет­ся вниз также слева направо. Пра­вее спуска лест­ни­ца переходит в го­ри­зон­таль­ную стену. Вы­со­та каждой ступени — 1 клетка, ширина — 1 клетка. Ко­ли­че­ство ступенек, ве­ду­щих вверх, и ко­ли­че­ство ступенек, ве­ду­щих вниз, неизвестно. Между спус­ком и подъ­емом ширина площадки — 1 клетка. Робот на­хо­дит­ся в клетке, рас­по­ло­жен­ной в на­ча­ле спуска. На ри­сун­ке указан один из воз­мож­ных способов рас­по­ло­же­ния стен и Ро­бо­та (Робот обо­зна­чен буквой «Р») .

Напишите для Ро­бо­та алгоритм, за­кра­ши­ва­ю­щий все клетки, рас­по­ло­жен­ные непосредственно над лестницей. Робот дол­жен закрасить толь­ко клетки, удо­вле­тво­ря­ю­щие данному условию. Например, для приведённого выше ри­сун­ка Робот дол­жен закрасить сле­ду­ю­щие клетки (см. рисунок).

Конечное рас­по­ло­же­ние Робота может быть произвольным. Ал­го­ритм должен ре­шать задачу для про­из­воль­но­го размера поля и лю­бо­го допустимого рас­по­ло­же­ния стен внут­ри прямоугольного поля. При ис­пол­не­нии алгоритма Робот не дол­жен разрушиться, вы­пол­не­ние алгоритма долж­но завершиться. Ал­го­ритм может быть вы­пол­нен в среде фор­маль­но­го исполнителя или за­пи­сан в тек­сто­вом редакторе. Со­хра­ни­те алгоритм в тек­сто­вом файле.

 

 

20.2 Введите с кла­ви­а­ту­ры 8 по­ло­жи­тель­ных целых чисел. Определите, сколь­ко из них де­лят­ся на 3 и при этом за­кан­чи­ва­ют­ся на 4. Про­грам­ма должна вы­ве­сти одно число: ко­ли­че­ство чисел, крат­ных 3 и окан­чи­ва­ю­щих­ся на 4.

 

Пример ра­бо­ты программы:

 

Входные данныеВыходные данные
12
14
24
54
44
33
84
114
4

Решение.

20.1 Следующий ал­го­ритм выполнит тре­бу­е­мую задачу.

 

нц пока не спра­ва свободно

закрасить

вверх

закрасить

вправо

кц

 

закрасить

вправо

 

нц пока снизу свободно

закрасить

вниз

закрасить

вправо

кц

 

20.2 Решение

 

var i, n, а : integer;

begin n : = 0;

for i : = 1 to 8 do

begin

readln(a);

if (a mod 3 = 0) and ( a mod 10 = 4) then

n : = n + 1 ; end;

writeln ( n );

end .

 

Для про­вер­ки правильности ра­бо­ты программы не­об­хо­ди­мо использовать сле­ду­ю­щие тесты:

 

Входные данныеВыходные данные
1

1

2

3

4

5

6

7

8

0
2

20

21

22

23

24

25

26

27

1
3

24

34

44

54

64

74

84

85

3