информатика
Математика
Информатика
Английский язык
Немецкий язык
Французcкий язык
Испанский язык
Физика
Химия
Биология
География
Обществознание
Литература
История
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 9 № 690

Запишите зна­че­ние пе­ре­мен­ной s, по­лу­чен­ное в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей программы. Текст про­грам­мы приведён на трёх язы­ках программирования.

 

Алгоритмический языкБейсикПаскаль
алг

нач

цел s, n

s := 2

нц для n от 2 до 5

s := s + n*2

кц

вывод s

кон

DNM n, s AS INTEGER

s = 2

FOR n = 2 TO 5

s = s + n*2

NEXT n

PRINT s

Var s, n: integer;

Begin

s := 2;

For n := 2 to 5 do

s := s + n*2;

Writeln(s);

End.

Пояснение.

Цикл «for i := 2 to 5 do» вы­пол­ня­ет­ся че­ты­ре раза. Каж­дый раз пе­ре­мен­ной s при­сва­и­ва­ет­ся зна­че­ние s + n*2. Найдём зна­че­ния s после каж­до­го шага, учитывая, что из­на­чаль­но s = 2: 6; 12; 20; 30.