информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 19 № 660

В ме­ди­цин­ском ка­би­не­те из­ме­ря­ли рост и вес уче­ни­ков с 5 по 11 классы. Ре­зуль­та­ты за­нес­ли в элек­трон­ную таблицу. Ниже при­ве­де­ны пер­вые пять строк таблицы:

 

ABCDE
1ФамилияИмяКлассРостВес
2АбашкинаЕлена916850
3АксеноваМария918371
4АлександровКонстантин717068
5АлексееваАнастасия816258
6АлиевАриф717157

 

Каждая стро­ка таб­ли­цы со­дер­жит за­пись об одном ученике. В столб­це А за­пи­са­на фамилия, в столб­це В — имя; в столб­це С — класс; в столб­це D — рост, в столб­це Е — вес учеников. Всего в элек­трон­ную таб­ли­цу были за­не­се­ны дан­ные по 211 уче­ни­кам в ал­фа­вит­ном порядке.

 

Выполните задание.

Откройте файл с дан­ной элек­трон­ной таб­ли­цей (расположение файла Вам со­об­щат ор­га­ни­за­то­ры экзамена). На ос­но­ва­нии данных, со­дер­жа­щих­ся в этой таблице, от­веть­те на два вопроса.

1. Каков рост са­мо­го вы­со­ко­го уче­ни­ка 10 класса? Ответ на этот во­прос за­пи­ши­те в ячей­ку Н2 таблицы.

2. Какой про­цент уче­ни­ков 8 клас­са имеет вес боль­ше 65? Ответ на этот во­прос с точ­но­стью не менее 2 зна­ков после за­пя­той за­пи­ши­те в ячей­ку НЗ таблицы.

 

 

task19.xls

Пояснение.

task19.xls

 

1. В столб­це F для каж­до­го уча­ще­го­ся за­пи­шем его рост, если он учит­ся в 10 клас­се и 0 в об­рат­ном случае. В ячей­ку F2 за­пи­шем формулу: =ЕСЛИ(С2=10;D2;0). Ско­пи­ру­ем фор­му­лу во все ячей­ки диа­па­зо­на F2:F212. Бла­го­да­ря ис­поль­зо­ва­нию от­но­си­тель­ных ссы­лок в столб­це F в стро­ках 2−212 будут за­пи­са­ны либо рост ученика, либо 0. Для того чтобы найти ответ, в ячей­ку Н2 внесём фор­му­лу =MAKC(F2:F212).

2. Для от­ве­та на вто­рой во­прос в столб­це G для каж­до­го уча­ще­го­ся за­пи­шем его вес, если он учит­ся в 8 клас­се и 0 в об­рат­ном случае. В ячей­ку G2 за­пи­шем фор­му­лу =ЕСЛИ(С2=8;Е2;0). Ско­пи­ру­ем фор­му­лу во все ячей­ки диа­па­зо­на G2:G212. Далее, чтобы опре­де­лить ко­ли­че­ство учащихся, вес ко­то­рых более 65 за­пи­шем в ячей­ку I1 фор­му­лу =СЧЁТЕСЛИ(G2:G212;">65") . Со­счи­та­ем ко­ли­че­ство уче­ни­ков 8 класса. В ячей­ку I2 за­пи­шем фор­му­лу =СЧЁТЕСЛИ(С2:С212;8). Вы­ра­зим по­лу­чен­ное зна­че­ние в про­цен­тах от об­ще­го числа учеников. Ре­зуль­тат за­пи­шем в ячей­ку НЗ: =I1*100/I2 Воз­мож­ны и дру­гие ва­ри­ан­ты решения, на­при­мер с ис­поль­зо­ва­ни­ем сортировок, филь­тров и. т. д.

 

Ответ: 1) 199; 2) 53,85.