информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 9 № 650

Запишите зна­че­ние пе­ре­мен­ной s, по­лу­чен­ное в ре­зуль­та­те ра­бо­ты сле­ду­ю­щей программы. Текст про­грам­мы приведён на пяти язы­ках программирования.

 

БейсикPython

DIM n, s AS INTEGER

s = 5

FOR n = 2 TO 4

    s = s + (n−1)

NEXT n

PRINT s

s = 5

for n in range(2,5):

    s = s + (n−1)

print (s)

ПаскальАлгоритмический язык

var s,n: integer;

begin

    s := 5;

    for n := 2 to 4 do

        s := s + (n−1);

    writeln(s);

end.

алг

нач

   цел s, n

   s := 5

   нц для n от 2 до 4

      s := s + (n−1)

   кц

   вывод s

кон

С++

#include <iostream>

using namespace std;

int main() {

     int s = 5;

     for (int n = 2; n <= 4; n++)

          s = s + (n−1);

     cout << s;

     return 0;

}

 

Пояснение.

Цикл «for i := 2 to 4 do» вы­пол­ня­ет­ся три раза. Каж­дый раз пе­ре­мен­ной s при­сва­и­ва­ет­ся зна­че­ние s + (n-1). Найдём зна­че­ния s после каж­до­го шага, учитывая, что из­на­чаль­но s = 5: 6; 8; 11.