СДАМ ГИА: РЕШУ ОГЭ
Образовательный портал для подготовки к экзаменам
Информатика
информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 9 № 630

Запишите зна­че­ние переменной s, по­лу­чен­ное в ре­зуль­та­те работы сле­ду­ю­щей программы. Текст про­грам­мы приведён на пяти язы­ках программирования.

 

БейсикPython

DIM i, s AS INTEGER

s = 3

FOR i = 2 TO 5

    s = s + 2*i

NEXT i

PRINT s

s = 3

for i in range(2,6):

    s = s + 2*i

print (s)

ПаскальАлгоритмический язык

var s,i: integer;

begin

    s := 3;

    for i := 2 to 5 do

        s := s + 2*i;

    writeln(s);

end.

алг

нач

   цел s, i

   s := 3

   нц для i от 2 до 5

      s := s + 2*i

   кц

   вывод s

кон

С++

#include <iostream>

using namespace std;

int main() {

     int s = 3;

     for (int i = 2; i <= 5; i++)

          s = s + 2*i;

     cout << s;

     return 0;

}

 

Пояснение.

Цикл «for i := 2 to 5 do» вы­пол­ня­ет­ся четыре раза. Каж­дый раз пе­ре­мен­ной s при­сва­и­ва­ет­ся значение s + 2*i. Найдём зна­че­ния s после каж­до­го шага, учитывая, что из­на­чаль­но s = 3: 7; 13; 21; 31.