СДАМ ГИА: РЕШУ ОГЭ
Образовательный портал для подготовки к экзаменам
Информатика
информатика
сайты - меню - вход - новости


Задания
Версия для печати и копирования в MS Word
Задания Д17 C1 № 620

В московской Библиотеке имени Некрасова в электронной таблице хранится список поэтов Серебряного века. Ниже приведены первые пять строк таблицы:

 

ABCDE
1ФамилияИмяОтчествоГод рожденияГод смерти
2АгаповБорисНиколаевич18991973
3АгнивцевНиколайЯковлевич18881932
4АдамовичГеоргийВикторович18921972
5АксёновИванАлександрович18841935
6АмариМихаилОсипович18821945

 

Каждая строка таблицы содержит запись об одном поэте. В столбце А записана фамилия, в столбце В — имя, в столбце С — отчество, в столбце D — год рождения, в столбце Е — год смерти. Всего в электронную таблицу были занесены данные по 150 поэтам Серебряного века в алфавитном порядке.

 

Выполните задание.

Откройте файл с данной электронной таблицей (расположение файла Вам сообщат организаторы экзамена). На основании данных, содержащихся в этой таблице, ответьте на два вопроса.

1. Определите количество поэтов, родившихся в 1888 году. Ответ на этот вопрос запишите в ячейку Н2 таблицы.

2. Определите в процентах, сколько поэтов, умерших позже 1930 года, носили имя Иван. Ответ на этот вопрос с точностью не менее 2 знаков после запятой запишите в ячейку НЗ таблицы.

 

 

task19.xls

Решение.

task19.xls

 

1. В ячейку Н2 запишем формулу, которая определяет количество поэтов, родившихся в 1888 году: =СЧЁТЕСЛИ(D2:D151; 1888).

2. Для ответа на второй вопрос, в столбце G для каждого поэта запишем его имя, если он умер позже 1930 года, и 0 в другом случае. В ячейку G2 запишем формулу =ЕСЛИ(Е2>1930; В2; 0). Скопируем формулу во все ячейки диапазона G3:G151. Далее, чтобы определить количество поэтов с именем Иван, запишем формулу в ячейку I1 формулу =СЧЁТЕСЛИ(G2:G151;"Иван"), получим 4. Сосчитаем количество поэтов, умерших позже 1930 года. В ячейку I2 запишем формулу =СЧЁТЕСЛИ(E2:E151;">1930"), получим 114. Выразим полученное значение в процентах от общего числа поэтов, умерших позже 1930 года. Результат запишем в ячейку НЗ: =I1*100/I2 Возможны и другие варианты решения, например с использованием сортировок, фильтров и т. д.

 

Ответ: 1) 5; 2) 3,51.