СДАМ ГИА: РЕШУ ОГЭ
Образовательный портал для подготовки к экзаменам
Информатика
информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 19 № 620

В мос­ков­ской Библиотеке имени Не­кра­со­ва в элек­трон­ной таблице хра­нит­ся список по­этов Серебряного века. Ниже при­ве­де­ны первые пять строк таблицы:

 

ABCDE
1ФамилияИмяОтчествоГод рожденияГод смерти
2АгаповБорисНиколаевич18991973
3АгнивцевНиколайЯковлевич18881932
4АдамовичГеоргийВикторович18921972
5АксёновИванАлександрович18841935
6АмариМихаилОсипович18821945

 

Каждая стро­ка таблицы со­дер­жит запись об одном поэте. В столб­це А за­пи­са­на фамилия, в столб­це В — имя, в столб­це С — отчество, в столб­це D — год рождения, в столб­це Е — год смерти. Всего в элек­трон­ную таблицу были за­не­се­ны данные по 150 по­этам Серебряного века в ал­фа­вит­ном порядке.

 

Выполните задание.

Откройте файл с дан­ной электронной таб­ли­цей (расположение файла Вам со­об­щат организаторы экзамена). На ос­но­ва­нии данных, со­дер­жа­щих­ся в этой таблице, от­веть­те на два вопроса.

1. Определите ко­ли­че­ство поэтов, ро­див­ших­ся в 1888 году. Ответ на этот во­прос запишите в ячей­ку Н2 таблицы.

2. Определите в процентах, сколь­ко поэтов, умер­ших позже 1930 года, но­си­ли имя Иван. Ответ на этот во­прос с точ­но­стью не менее 2 зна­ков после за­пя­той запишите в ячей­ку НЗ таблицы.

 

 

task19.xls

Пояснение.

task19.xls

 

1. В ячей­ку Н2 за­пи­шем формулу, которая опре­де­ля­ет количество поэтов, ро­див­ших­ся в 1888 году: =СЧЁТЕСЛИ(D2:D151; 1888).

2. Для от­ве­та на вто­рой вопрос, в столб­це G для каж­до­го поэта за­пи­шем его имя, если он умер позже 1930 года, и 0 в дру­гом случае. В ячей­ку G2 за­пи­шем формулу =ЕСЛИ(Е2>1930; В2; 0). Ско­пи­ру­ем формулу во все ячей­ки диапазона G3:G151. Далее, чтобы опре­де­лить количество по­этов с име­нем Иван, за­пи­шем формулу в ячей­ку I1 фор­му­лу =СЧЁТЕСЛИ(G2:G151;"Иван"), получим 4. Со­счи­та­ем количество поэтов, умер­ших позже 1930 года. В ячей­ку I2 за­пи­шем формулу =СЧЁТЕСЛИ(E2:E151;">1930"), получим 114. Вы­ра­зим полученное зна­че­ние в про­цен­тах от об­ще­го числа поэтов, умер­ших позже 1930 года. Ре­зуль­тат запишем в ячей­ку НЗ: =I1*100/I2 Воз­мож­ны и дру­гие варианты решения, на­при­мер с ис­поль­зо­ва­ни­ем сортировок, филь­тров и т. д.

 

Ответ: 1) 5; 2) 3,51.