информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 9 № 610

Запишите зна­че­ние переменной k, по­лу­чен­ное в ре­зуль­та­те работы сле­ду­ю­щей программы. Текст про­грам­мы приведён на пяти язы­ках программирования.

 

БейсикPython

DIM k, i AS INTEGER

k = 2

FOR i = 0 TO 2

    k = i + 3 * k

NEXT i

PRINT k

k = 2

for i in range(3):

    k = i + 3 * k

print (k)

ПаскальАлгоритмический язык

var k, i: integer;

begin

    k := 2;

    for i := 0 to 2 do

        k := i + 3 * k;

    writeln(k);

end.

алг

нач

   цел k, i

   k := 2

   нц для i от 0 до 2

      k := i + 3 * k

   кц

   вывод k

кон

С++

#include <iostream>

using namespace std;

int main() {

     int k = 2;

     for (int i = 0; i <= 2; i++)

          k = i + 3 * k;

     cout << k;

     return 0;

}

 

Пояснение.

Цикл «for i := 0 to 2 do» вы­пол­ня­ет­ся три раза. Каж­дый раз пе­ре­мен­ной k при­сва­и­ва­ет­ся значение i + 3*k. Найдём зна­че­ния k после каж­до­го шага, учитывая, что из­на­чаль­но k = 2: 6; 19; 59.