информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 19 № 600

В мос­ков­ской Биб­лио­те­ке имени Не­кра­со­ва в элек­трон­ной таб­ли­це хра­нит­ся спи­сок по­этов Се­реб­ря­но­го века. Ниже при­ве­де­ны пер­вые пять строк таблицы:

 

ABCDE
1ФамилияИмяОтчествоГод рожденияГод смерти
2АгаповБорисНиколаевич18991973
3АгнивцевНиколайЯковлевич18881932
4АдамовичГеоргийВикторович18921972
5АксёновИванАлександрович18841935
6АмариМихаилОсипович18821945

 

Каждая стро­ка таб­ли­цы со­дер­жит за­пись об одном поэте. В столб­це А за­пи­са­на фамилия, в столб­це В — имя, в столб­це С — отчество, в столб­це D — год рождения, в столб­це Е — год смерти. Всего в элек­трон­ную таб­ли­цу были за­не­се­ны дан­ные по 150 по­этам Се­реб­ря­но­го века в ал­фа­вит­ном порядке.

 

Выполните задание.

Откройте файл с дан­ной элек­трон­ной таб­ли­цей (расположение файла Вам со­об­щат ор­га­ни­за­то­ры экзамена). На ос­но­ва­нии данных, со­дер­жа­щих­ся в этой таблице, от­веть­те на два вопроса.

1. Определите ко­ли­че­ство поэтов, ро­див­ших­ся в 1889 году. Ответ на этот во­прос за­пи­ши­те в ячей­ку Н2 таблицы.

2. Определите в процентах, сколь­ко поэтов, умер­ших позже 1940 года, но­си­ли имя Сергей. Ответ на этот во­прос с точ­но­стью не менее 2 зна­ков после за­пя­той за­пи­ши­те в ячей­ку НЗ таблицы.

 

 

task19.xls

Пояснение.

task19.xls

 

1. В ячей­ку Н2 за­пи­шем формулу, ко­то­рая опре­де­ля­ет ко­ли­че­ство поэтов, ро­див­ших­ся в 1889 году: =СЧЁТЕСЛИ(D2:D151; 1889).

2. Для от­ве­та на вто­рой вопрос, в столб­це G для каж­до­го поэта за­пи­шем его имя, если он умер позже 1940 года, и 0 в дру­гом случае. В ячей­ку G2 за­пи­шем фор­му­лу =ЕСЛИ(Е2>1940; В2; 0). Ско­пи­ру­ем фор­му­лу во все ячей­ки диа­па­зо­на G3:G151. Далее, чтобы опре­де­лить ко­ли­че­ство по­этов с име­нем Сергей, за­пи­шем фор­му­лу в ячей­ку I1 фор­му­лу =СЧЁТЕСЛИ(G2:G151;"Сергей"), получим 5. Найдём количество поэтов, умерших после 1940 года, для этого в ячеку I2 запишем формулу =СЧЁТЕСЛИ(E2:E151;">1940"), получим 83. Найдём сколько поэтов, умерших после 1940 года носили имя Сергей, результат запишем в ячейку НЗ: =I1*100/I2 Воз­мож­ны и дру­гие ва­ри­ан­ты решения, на­при­мер с ис­поль­зо­ва­ни­ем сортировок, филь­тров и т. д.

 

Ответ: 1) 8; 2) 6,02.