информатика
сайты - меню - вход - новости




Задания
Версия для печати и копирования в MS Word
Задание 9 № 590

Запишите зна­че­ние переменной k, по­лу­чен­ное в ре­зуль­та­те работы сле­ду­ю­щей программы. Текст про­грам­мы приведён на пяти язы­ках программирования.

 

БейсикPython

DIM k, i AS INTEGER

k = 4

FOR i = 1 TO 3

    k = i + 2 * k

NEXT i

PRINT k

k = 4

for i in range(1,4):

    k = i + 2 * k

print (k)

ПаскальАлгоритмический язык

var k, i: integer;

begin

    k := 4;

    for i := 1 to 3 do

        k := i + 2 * k;

    writeln(k);

end.

алг

нач

   цел k, i

   k := 4

   нц для i от 1 до 3

      k := i + 2 * k

   кц

   вывод k

кон

С++

#include <iostream>

using namespace std;

int main() {

     int k = 4;

     for (int i = 1; i <= 3; i++)

          k = i + 2 * k;

     cout << k;

     return 0;

}

 

Пояснение.

Цикл «for i := 1 to 3 do» вы­пол­ня­ет­ся три раза. Каж­дый раз пе­ре­мен­ной k при­сва­и­ва­ет­ся значение i + 2*k. Найдём зна­че­ния k после каж­до­го шага, учитывая, что из­на­чаль­но k = 4: 9; 20; 43.